0

I have a laptop running 17.04 Gnome: 1 admin user and 2 standards.

While setting the laptop up, I used the software centre to install some apps while logged in as one of my standard user accounts. Now that account is getting stuck, asking for the admin password in order to "update the catalogue".

It happens every day or two, but only on that standard account and not the other. I am guessing that because it has been run once in that account (and I provided the admin pwd) it has somehow been "activated" in the account.

How can I stop this? I have done lots of web searching and looked in dconf and not found anything to help.

The relevant log entry seems to be this:

Operator of unix-session:11 FAILED to authenticate to gain authorization for action org.debian.apt.update-cache for system-bus-name::1.438 [/usr/bin/gnome-software --gapplication-service] (owned by unix-user:kids)

Any help would be much appreciated.

0

Ok. I have been doing lots of research into the options for this. There is an autostart file in /etc/xdg/autostart which launches the gnome-software comand. (gnome-software-service.desktop)

[Desktop Entry]
Type=Application
Name=GNOME Software
Exec=/usr/bin/gnome-software --gapplication-service
OnlyShowIn=GNOME;Unity;
NoDisplay=true
X-Ubuntu-Gettext-Domain=gnome-software

I couldnt find a way to edit this file to only run inside my admin account. Instead, I have copied the file into my non-admin users under ~/.config/autostart/ and edited the file to read "NotShownIn=Gnome;Unity;".

The autostart file in your home directory is meant to over-ride the system-wide one in /etc. I will report back if this is successful.

  • yes, this works perfectly. – chrisonbuntu Jun 20 '17 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.