1

I recently installed Ubuntu GNOME 17.04 x64 with a bootable USB (using rufus).
My laptop is a Dell Insprion 15 5000, i7 up to 3.1 Ghz and a AMD Radeon GPU.

Right after the installation, I had some problems like the whole system freezing after I logged in. Thankfully I fixed this problem by editing one file:

$ sudo nano /etc/default/grub

and changed

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="radeon.modeset=0 amdgpu.runpm=0"

The problem was solved, everything was working fine until one day when Ubuntu all of a sudden crashed while I was watching a video. I didn't think much about it and restarted, but a few hours later it crashed again.

It looks like this might have something to do with the AMD Radeon GPU again. I checked other posts and website and they said to add something else on GRUB_CMDLINE_LINUX_DEFAULT but I don't know if that will fix the problem or will the previous problem of Ubuntu crashing after login come back.

I also found out that the laptop was getting quite hot. Approx ~10-20 before a crash, I checked the max temperature and it was 78 degree C. So i'm not sure if it could be overheating issues.

Some help would be appreciated :) Thanks!

EDIT:

superpykkon@superpykkon ~/Desktop> dpkg -l intel-microcode
dpkg-query: no packages found matching intel-microcode
superpykkon@superpykkon ~/Desktop> dpkg -l thermald
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                            Version              Architecture         Description
+++-===============================-====================-====================-====================================================================
ii  thermald                        1.5.4-4ubuntu1       amd64                Thermal monitoring and controlling daemon
superpykkon@superpykkon ~/Desktop> free -h
              total        used        free      shared  buff/cache   available
Mem:           3.8G        1.7G        1.1G         36M        997M        1.8G
Swap:          2.0G          0B        2.0G
superpykkon@superpykkon ~/Desktop> 

EDIT #2:

superpykkon@superpykkon:~$ cat /etc/crypt*
cat: '/etc/crypt*': No such file or directory
superpykkon@superpykkon:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=1c608749-0ff4-4c10-abf4-323c481a7936 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=5003-97BA  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
superpykkon@superpykkon:~$  
  • Show me the terminal output of dpkg -l intel-microcode and dpkg -l thermald and free -h. Edit your question with that info... not in the comments please. Start comments directed to me with @heynnema or I may miss them. – heynnema May 28 '17 at 19:22
  • There you go, @heynnema Oh and, I recently added "nomodeset" to the GRUB_CMDLINE_LINUX_DEFAULT, I'm currently testing if that solved the problem or not. So far, I've encountered no system crashes . – LollyPop Lolly May 29 '17 at 12:58
  • I would check to make sure that you have the latest BIOS for your machine by going to the manufacturer's web site. I'd install intel-microcode to make sure that your processors were running the latest microcode. If that didn't fix it, I'd look into writing a custom /etc/thermald/thermal-conf.xml tailored to your configuration. See man thermald and man thermal-conf.xml. More on that later. – heynnema May 29 '17 at 13:30
  • Hello @heynnema, I think the problem is fixed. After adding "nomodeset" to GRUB_CMDLINE_LINUX_DEFAULT, my laptop isn't crashing anymore :D. – LollyPop Lolly May 29 '17 at 16:37
  • I really don't think that's a permanent fix. With nomodeset you can't set the video display to optimal settings in the System Settings. It just may point to a video driver issue which might be solved with a newer version of the driver. I'd still do the intel-microcode and work the temp issue with thermald... as you still have problems there. Did you check the BIOS? I recommended all of these things for a reason. – heynnema May 29 '17 at 17:01
0

From the comments...

Summary...

  • we updated the Dell BIOS from 1.1.5 to 1.2.8
  • we installed intel-microcode
  • we ran the memtest memory diagnostic
  • we replaced what must have been a faulty RAM stick, 'cause it's working now!
  • and more I can't remember...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.