1

Live usb with 4gb persistent. I follow these steps:-

  1. I press e on grub2 at Boot.
  2. I add pci=nomsi at the end of quiet splash. Its effects works perfectly.
  3. To make it permanent i then in terminal and type this command-

    gksudo gedit /etc/default/grub
    
  4. I make these changes in the text file

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"
    

I get these in terminal after that-

(gedit:5013): WARNING: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported
(gedit:5013): WARNING: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported
(gedit:5013): WARNING: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported    
(gedit:5013): WARNING: Set document metadata failed: Setting attribute metadata::gedit-spell-enabled not supported
(gedit:5013): WARNING: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported
(gedit:5013): WARNING: Set document metadata failed: Setting attribute metadata::gedit-position not supported
  1. Then in terminal i type-

    sudo update-grub
    

Everythings works fine but it doest load with that boot parameter next time i do a reboot.

EDIT :- I tried these two seperate method also and they have issue of there own. LINK - link

  1. Boot repair - It just doest open.

    2.grub-crustomizer - NOte- I also added device.map manually but what to do with grub.cfg now.

enter image description here

enter image description here

I want to add boot parameter(pci=nomsi) permanently by which ever method works. Thanks,


So after trying sudo nano /etc/default/grub. I see this after every fresh boot.enter image description here

Despite that, effects of pci=nomsi are not taking place and system is not booted with that parameter. How do i know that? Because when i type this command- cat /proc/cmdline

there is no (pci=nomis) at the end of quite splash. Pic - enter image description here

  • Please re-do it using nano text editor.. before proceeding are you familiar with nano? – George Udosen May 28 '17 at 6:34
  • NO. How should i proceed now? – Jason May 28 '17 at 6:36
  • Let me post an answer so you can follow – George Udosen May 28 '17 at 6:36
  • Wait!! I have tried this before - sudo nano /etc/default/grub – Jason May 28 '17 at 6:38
  • 1
    I didnt know what to do after that. I will follow your answer and post back asap. – Jason May 28 '17 at 6:43
2

This is how I fixed this issue. In my case, I had 2 Linux operating systems installed. One was Ubuntu and the other was Kali.

In fact, I almost had the same issue that you were facing. (i.e: I was not able to add kernal boot parameters(pci=nomsi) permanently)

The mistake that I did was I tried executing all the commands to add boot parameters to Ubuntu from Ubuntu itself. But unfortunately, the bootloader was installed by Kali Linux. Hence all the changes that I made from Ubuntu were not reflected in Kali's bootloader.

Fix:

1.Boot the operating system which installed the bootloader.(In my case it was Kali)

2.From a terminal run:

sudo nano /boot/grub/grub.cfg

3.Under the menuentry of your operating system(to which you want to add the boot parameter) find the line starting with linux and add the boot parameter(pci=nomsi) to the end of it. For Ubuntu, after adding the parameter that line should look something like this:

linux   /vmlinuz-4.13.0-36-generic root=UUID=22aca2b7-9520-4c80-925b-10bde01378d5 ro  quiet splash pci=nomsi $vt_handoff

4.Now save the file and close it.

5.Finally, update grub: sudo update-grub

1

Please re-edit that document and this time use nano text editor.

How to use nano:

  1. Open the document in question:

    sudo nano /etc/default/grub
    
  2. Do the edit re-move that entry you made and re-add it again:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi"
    
  3. Now save the file with: Ctrl+o, then Enter

  4. Close nano with: Ctrl+x

  5. Now update grub: sudo update-grub

  6. Reboot your system

  • "booted with that parameter" please explain? – George Udosen May 28 '17 at 6:52
  • With or without that parameter is the parameter entry not seen in that file after reboot? – George Udosen May 28 '17 at 7:02
  • 1
    Sorry, its wihout that parameter. I also added an answer, it will make some sense now. Thanks again, its my very time touching a linux OS. Please understand. – Jason May 28 '17 at 7:37
  • @Jason did this issue start after you first tried to change grub using that grub customizer. – George Udosen May 28 '17 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.