0

When I run Deja-dup for the first time, it makes a backup just fine. However, when I run it a couple of days later to do an update, I get the following error: Error splicing file: Input/output error

This by itself was no help so I took the advice of several postings and ran it from the terminal shell as follows: DEJA_DUP_DEBUG=1 deja-dup --backup

It repeatedly produced the following error:

DUPLICITY: DEBUG 1
DUPLICITY: . Backtrace of previous error: Traceback (innermost last):
DUPLICITY: .   File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 365, in inner_retry
DUPLICITY: .     return fn(self, *args)
DUPLICITY: .   File "/usr/lib/python2.7/dist-packages/duplicity/backend.py", line 563, in get
DUPLICITY: .     self.backend._get(remote_filename, local_path)
DUPLICITY: .   File "/usr/lib/python2.7/dist-packages/duplicity/backends/giobackend.py", line 146, in _get
DUPLICITY: .     self.__copy_file(source_file, target_file)
DUPLICITY: .   File "/usr/lib/python2.7/dist-packages/duplicity/backends/giobackend.py", line 119, in __copy_file
DUPLICITY: .     None, self.__copy_progress, None)
DUPLICITY: .  Error: g-io-error-quark: Error splicing file: Input/output error (0)
DUPLICITY: . 

DUPLICITY: WARNING 1
DUPLICITY: . Attempt 2 failed. Error: g-io-error-quark: Error splicing file: Input/output error (0)

That still does not provide me with any determination as to how to resolve the issue. Does anyone have any advice on how to interpret the message or resolve this error?

0

This usually happens because the disk you are backing up to is formatted with a system that cannot handle large file sizes (FAT or something like that) - perhaps you are backing up to a USB thumb drive? If that is the case, you will need to reformat the disk to EXT4 or similar to prevent the error.

| improve this answer | |
  • The drive is a networked 2TB drive formatted as NTFS. – elyod72 May 27 '17 at 21:30
  • Other answers I have seen on this issue say that the drive is failing in that case. I personally have only encountered this FAT issue. – Organic Marble May 27 '17 at 23:49
0

I found that the drive is in fine condition and is not the problem. As I dug deeper into the files that backup was trying to compress, several filenames started with two dashes('--'). I think the program was assuming they were tags and was erroring out when it came to these files. I renamed the files and ran the backup again. This time it worked fine. So, if anyone else runs into this problem, pay close attention to the filenames that the program is trying to backup.

| improve this answer | |
0

I have the same problem with a WD MyCloud EXT2 Ultra with all the latest firmware etc. Its definitely a bug they know about (Bug #1591325). However, when/if it will get fixed is anybody's guess.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.