0

I am able to see the WiFi connection, but I am not able to connect to it.

$ iwconfig 
wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

enp1s0    no wireless extensions.

enp0s20u1  no wireless extensions.

I updated my system using:

sudo apt-get update && sudo apt-get dist-upgrade

then rebooted it, but nothing happened.

$ lspci -knn | grep Net -A3**
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be, wl

update

$ sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 07
       serial: 70:5a:0f:d3:46:d0
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:43 ioport:4000(size=256) memory:c1200000-c1200fff memory:c1000000-c1003fff
  *-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: 68:14:01:68:3e:67
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.8.0-36-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:17 ioport:3000(size=256) memory:c1100000-c1103fff
  *-network
       description: Ethernet interface
       physical id: 3
       logical name: enp0s20u1
       serial: d6:e5:75:79:38:fc
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.209 link=yes multicast=yes

UPDATE: I got this error message related to wifi.How to solve this. error

Can i purge this ?

$ locate rtlwifi-new-dkms
/home/maddy/.cache/upstart/update-notifier-crash-_var_crash_rtlwifi-new-dkms.0.crash.log.1.gz
/home/maddy/.cache/upstart/update-notifier-crash-_var_crash_rtlwifi-new-dkms.0.crash.log.2.gz
/home/maddy/.cache/upstart/update-notifier-crash-_var_crash_rtlwifi-new-dkms.0.crash.log.3.gz
/home/maddy/.cache/upstart/update-notifier-crash-_var_crash_rtlwifi-new-dkms.0.crash.log.4.gz
/home/maddy/.cache/upstart/update-notifier-crash-_var_crash_rtlwifi-new-dkms.0.crash.log.5.gz
/home/maddy/.cache/upstart/update-notifier-crash-_var_crash_rtlwifi-new-dkms.0.crash.log.6.gz
/home/maddy/.cache/upstart/update-notifier-crash-_var_crash_rtlwifi-new-dkms.0.crash.log.7.gz
/usr/share/rtlwifi-new-dkms
/usr/share/rtlwifi-new-dkms/postinst
/var/cache/apt/archives/rtlwifi-new-dkms_0.10_all.deb
/var/lib/dpkg/info/rtlwifi-new-dkms.list
/var/lib/dpkg/info/rtlwifi-new-dkms.md5sums
/var/lib/dpkg/info/rtlwifi-new-dkms.postinst
/var/lib/dpkg/info/rtlwifi-new-dkms.prerm
| improve this question | | | | |
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. – Pilot6 May 27 '17 at 19:59
  • @Pilot6 i updated my post , can you suggest something now. – inrsaurabh May 28 '17 at 6:18
  • 3
    Possible duplicate of Rtl8723be WiFi incredibly weak – Pilot6 May 28 '17 at 8:20
  • @Pilot6 I tried the command you mentioned on this link , still problem is not solved . It keep asking for the password after some trying to connect to wifi. – inrsaurabh May 28 '17 at 10:58
  • Did you try both ant_sel=2 and 1? Did you reboot after the command? What is the kernel version uname -a? – Pilot6 May 28 '17 at 11:04

Browse other questions tagged or ask your own question.