1

I have installed mps-youtube program with pip. The program runs in terminal with the command 'mpsyt', no matter from which location i run the terminal. I have created a .desktop file like this:

[Desktop Entry]
Type=Application
Name=MPS-YouTube
Exec=mpsyt
Terminal=true
Icon=/home/john/Pictures/Icons/YouTube_01.png

But when I execute the shortcut it says 'there was an error launching the application'.

I also tried with Exec=sh -c 'mpsyt' but it does nothing, in this case even massage is missing! I think it is due to the pip installation because when I install this program from the Synaptic the shortcut works fine but the version is older. Also the command is not recognized from Alt+F2 box.

So how can I see what is causing this error?

  • Did you try to run other commands? Amd did you make it executable? – thangdc94 May 27 '17 at 18:09
  • @thangdc94 Yes if I change mpsyt with gedit it opens gedit! – Pekov May 27 '17 at 18:11
  • 1
    Try this to debug your desktop entry. You think you should try to use absolute path. – thangdc94 May 27 '17 at 18:17
1

Thanks to thangdc94 for the comments. I have found the solution - the exec line should be Exec=bash -i -c "mpsyt". Now it works perfect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.