3

CPU: Intel Core i7 870 ... number of cores = 4

I installed Ubuntu 17.04 64-bit (twice; and even tried Ubuntu MATE 17.04 64-bit - same thing). It seems that only 1 of 4 cores is used:

$ lscpu
 Architecture:          x86_64
 CPU op-mode(s):        32-bit, 64-bit
 Byte Order:            Little Endian
 CPU(s):                1
 On-line CPU(s) list:   0
 Thread(s) per core:    1
 Core(s) per socket:    1
 Socket(s):             1
 NUMA node(s):          1
 Vendor ID:             GenuineIntel
 CPU family:            6
 Model:                 30
 Model name:            Intel(R) Core(TM) i7 CPU         870  @ 2.93GHz
 Stepping:              5
 CPU MHz:               2926.117
 BogoMIPS:              5852.23
 Virtualization:        VT-x
 L1d cache:             32K
 L1i cache:             32K
 L2 cache:              256K
 L3 cache:              8192K
 NUMA node0 CPU(s):     0
 Flags:                 fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm tpr_shadow vnmi flexpriority ept vpid dtherm ida

$ nproc
 1

In the BIOS settings I can choose between using 1, 2, or All cores, but it doesn't matter which value I select, ubuntu uses only one.

Do you have any ideas what might be wrong here? Could I have possibly disabled the other cores somehow?

  • Possibly related: askubuntu.com/a/247211/518562 – You'reAGitForNotUsingGit May 27 '17 at 17:55
  • thanks for the link. Could not find a BIOS value Installer OS select but I checked if kernel boot parameter nolapic was used, which was mentioned in the answer - and yes, that was it – CL Fay May 27 '17 at 18:21
2

I checked the kernel boot parameters and (don't know why but) nolapic was set. After removing this parameter and rebooting everything was fine.

In detail: I edited /etc/default/grub and removed nolapic in the line GRUB_CMDLINE_LINUX="..." and then updated grub sudo update-grub and rebooted.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.