22

When I log into my Ubuntu terminal tty1, I get a message

failed to connect to http://changelogs.ubuntu.com/meta-release

I try various things, then I get an error message telling me

could not resolve us.archive.ubuntu.com

My internet connectivity is apparently disabled and I could not configure it.

I tried rebooting but nothing changed.

  • Please explain your issue with more details. When you see this message ? Can you use this command sudo apt update ? Do you set any proxy for your system ? Can you ping any sites ? – Ali Razmdideh May 27 '17 at 14:44
  • When I use sudo apt update i get the following err:1 http:/us.archive.ubuntu.com/ubuntu zesty InRelease could not resolve 'us.archive.ubuntu.com' err:2 http:/us.archive.ubuntu.com/ubuntu zesty-updates InRelease could not resolve 'us.archive.ubuntu.com' – habib May 27 '17 at 14:54
  • Do you set proxy for your system or shell ? What the output of this command ping us.archive.ubuntu.com -c 4 – Ali Razmdideh May 27 '17 at 14:58
  • err:3 http:/us.archive.ubuntu.com/ubuntu zesty-backports InRelease could not resolve 'us.archive.ubuntu.com – habib May 27 '17 at 14:59
  • 1
    This question shouldn't have been closed as duplicate. The two are related for sure, but they are not duplicates. All of the answers on the other question deal with network configuration problems. However I have just experienced this error message showing up on a system which doesn't have any such configuration problems. The answer below documents why the error message persists even if there is no networking problem and provides information on how one can make the error message go away. – kasperd Feb 24 at 20:47
29

I had this same problem with 17.10, but I'm betting the same applies to other recent versions as well.

Those MOTD messages are generated by scripts in /etc/update-motd.d. The exact script that generates that specific line is /etc/update-motd.d/91-release-upgrade, which also runs /usr/lib/ubuntu-release-upgrader/release-upgrade-motd. This last script will check for new releases and write output into /var/lib/ubuntu-release-upgrader/release-upgrade-available.

The script will only update the file every 24 hours. So if you wait long enough, the file will go stale and the script will update the file anyway. But, if you want to update it immediately, just remove /var/lib/ubuntu-release-upgrader/release-upgrade-available and run /etc/update-motd.d/91-release-upgrade and it should start working correctly.

I created this problem because when I first setup my 17.10 server, I had a typo in my DNS server address.

  • 8
    Because I can't comment on the answer of @anthony-cascianelli (reputation < 50) I'm posting an answer instead. After removing /var/lib/ubuntu-release-upgrader/release-upgrade-available, run /usr/lib/ubuntu-release-upgrader/release-upgrade-motd instead of /etc/update-motd.d/91-release-upgrade. This is what worked for me. – eiro Jan 24 '18 at 7:03
  • In my case, simply removing /var/lib/ubuntu-release-upgrader/release-upgrade-available was enough. Next time you login, it will see there's no cache and run the check script automatically. – Dave S Sep 29 '18 at 11:16
  • Oh my god. Thank you, man. There was lots of other suggestions around the internet for this error. The were talking about support for https proxies and whatnot - which seemed strange to me. Your answer was exact on the spot: I also had a DNS problem the first boot, which then evidently literally tainted this file "forever" (i.e. for 24 hours). – stolsvik Nov 18 '18 at 13:24
  • 1
    I got the same problem on Ubuntu Server 18.04. The error message is the same except it has -lts at the end. In my case there appears to have been no configuration error. The error message showed up after the system has been running for weeks without any problems. So apparently the error message can show up spontaneously. Too bad this question is closed as a duplicate, since your answer clearly shows that the bad output can persist even if none of the problems mentioned in the supposed duplicate are present. – kasperd Feb 24 at 20:35
  • 1
    Since this is still a topic of discussion (and I just had to research this too) : The original report is about a bug that has been fixed: askubuntu.com/a/1154537/793416 – TonyG Jun 28 at 1:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.