2

I am using plank dock so I want to completely disable the unity launcher in ubuntu 16.04.

I used the autohide method and set the reveal pressure very high. But there are there are two problems with this method:

  1. When I open unity dash by pressing the Super key, the launcher reveals.

  2. When I minimize an application then the app icon pops out from left side of the hidden launcher.

I want to completely disable it.

1
  • Short answer: not possible unless you change Unity source code and recompile it. This has been asked thousands of times before, and the answer is the same May 27 '17 at 14:29
5

Answer to my own question:

It can be done by editing the source code and remove the lines that are used to show the launcher.

I edited the files and recompiled the package. You don't have to reinstall the complete package, it can be done by replacing only one file.

libunityshell.so

Download the file with given link and replace the file /usr/lib/x86_64-linux-gnu/compiz/libunityshell.so with downloaded file.

Backup the file before replacing.

Set the launcher in autohide mode and restart your pc.

After restart :

  • No launcher revealing when you move mouse pointer to left side.
  • No launcher wake up while launching unity dash.
  • No icon popped out from launcher while minimizing an application.

Means, this will completely disable the unity launcher.

This package is compiled in ubuntu 16.04 (x64) Unity 7.4.0. It works fine for me.

For other than Ubuntu 16.04 (x64) Unity 7.4.0 use the following link

Compile Unity without launcher

It is not working with unity 7.4.5

13
  • Sanjay Prajapat, I've been trying to do this for a long time and I'm really excited about this workaround you have provided, however, if you don't mind me asking, could you tell me whether or not this might work on Ubuntu 16.04.2? Forgive me if this is a noob's question, but I'm really not sure if there's any significant differences between 16.04 and 16.04.2 that could, maybe, lead to any kind of incompatibility. So, I'd better ask first. Thanks for your time.
    – user48949
    Jul 6 '17 at 17:38
  • Thank you, this worked perfectly on 16.04. Now no more annoying launcher popping out every time I hit the super key. Jan 4 '18 at 18:05
  • is it work on ubuntu 14.4 too ? Feb 9 '18 at 2:10
  • @burhanuddinabbas , I don't know about ubuntu 14.04, but you can try. But make the backup of the original file , if anything went wrong then restore it. Feb 11 '18 at 10:52
  • @Sanjay Prajapat, its impossible to even try in ubuntu 14.04 because the directory you had specify is not even exist . specifically i would say that no compiz folder is available there Feb 11 '18 at 16:15
1

As far as I know, you can't, the best thing you can do is to go to System Settings > Appearance > Behavior here you can turn on 'Auto hide' for the launchpad, and then turn the sensitivity all the way down, now it almost never shows up unless you press super key.

0

I'm not familiar with plank because I use cairo-dock but there is a cairo-dock (GNOME) desktop that can be loaded at login and there is no unity dock but you also lose the panel.

Not the answer you're looking for? Browse other questions tagged or ask your own question.