4

I recently installed Ubuntu 16.04 as a second OS alongside Windows 7. Installation process went smoothly and after it was done I also downloaded nVidia driver for my graphics card and installed it. Everything worked fine, yesterday I switched between Win7 and Ubuntu many times without a single problem, I've also set up screen resolution in Ubuntu to my monitor's native FullHD (which wasn't possible without nVidia driver) and everything was ok. I installed some software - KallistiOS and WineHQ. All was fine.

But today I tried to install mono-devel package which is sometimes required by WineHQ. I couldn't install it as I kept getting some error message (something about lock). I wish I remember what it was, but I just can't. I searched the Internet to solve this problem, I messed around a little bit trying to resolve the issue and when I restarted my computer for any time today I noticed the screen resolution change in login screen - it was back to 640x480 from 1920x1080. From there it got worse, because after typing in my password and hitting Enter I was briefly shown with fsck message saying that /dev/sda3 is clean and after that I returned to login screen. Anytime I try to login this scheme repeats - fsck message is shown for a brief moment, after that system returns to login screen.

After searching the web I determined that the problem probably isn't with fsck, but that I'm stuck in a login loop. I'm stumped, because I don't know what to do to resolve this issue. I still have access to terminal by Ctrl+Alt+F1. Removing .Xauthority with command rm .Xauthority (as someone here in another topic suggested) didn't help.

I didn't install any other graphics driver, so I'm pretty sure this login loop doesn't have anything to do with it (despite that resolution change). Unfortunately, I cannot check what the whole problem with Mono and lock was, since I was searching the Internet on Ubuntu and not on Win7 (as I can't login on Ubuntu). I also tried editing /etc/default/grub as written here: 12.04.3 can start only after press "resume" in rescue mode (every boot) - problem with Nvidia driver , but it didn't help, too.

EDIT: This: Ubuntu gets stuck in a login loop didn't resolve my issue.

closed as off-topic by mikewhatever, Android Dev, Charles Green, karel, Zanna May 27 '17 at 15:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Charles Green, karel, Zanna
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Possible duplicate of Ubuntu gets stuck in a login loop – Android Dev May 27 '17 at 12:18
  • Was this the "lock" error you were talking about? – Android Dev May 27 '17 at 12:21
  • Yes, that was exactly the lock error I got. I also tried doing what guy here: askubuntu.com/questions/223501/… suggested, but nothing helped. – mentor93 May 27 '17 at 12:31
  • Just in case, I did not delete the lock file, I only tried killing process. – mentor93 May 27 '17 at 12:38
  • If you have the symptoms of "login loop" but it is not solved by deleting the user's .Xauthority file, then the next things I would check are (1) that the user's home directory is writeable and not full (ls -ld $HOME ; df -h $HOME) and (2) that the user's desktop session exists (ls /usr/share/xsessions/). The contents of the user's .xsession-errors file may be helpful as well. – steeldriver May 27 '17 at 12:51
0

I decided to reinstall Ubuntu, so the issue is gone now, although not resolved.

Not the answer you're looking for? Browse other questions tagged or ask your own question.