0

When players chat on my Ubuntu Minecraft server they can see the chat clearly in the game and it's fine. However when I look at the terminal all I see is 1 bracket for each time they enter something in as shown in the picture shown: picture of chat in terminal

When I also look at my latest.log file using vim the chat shows up but with odd characters here: latest.log file

With some of the minecraft commands it also displays weird characters as shown:

[23:33:29] [Server thread/INFO]: [PermissionsEx] Permissions file successfully reloaded
[23:33:29] [Server thread/INFO]: ^[[0;37;1mPermissions reloaded^[[m

I've tried looking at this thread Pressing enter produces ^M instead of a newline and tried to use the command "stty sane" but that didn't help. My stty settings also have icrnl enabled as well.

I've also tried to restart my server but it still shows the same characters.

  • They are ANSI escape codes. 0;37;1m means bold white text. – Chai T. Rex May 28 '17 at 1:50
  • But what about the player chat, it is hidden by a bracket, can you explain the reasoning behind that? – J4102 May 28 '17 at 2:41
0

Those characters are terminal color codes. The log file doesn't filter those out, and Vim shows them explicitly instead of changing colors on you.

  • But what about the player chat, it is hidden by a bracket, can you explain the reasoning behind that or have some sort of solution to that? And is there anyway where I can just have vim make the color codes just show the color? – J4102 May 28 '17 at 3:29
  • You can use cat instead of vim. Vim is an editor; if you couldn't edit escape sequences, that would be a problem. I don't know what happens to be logging [ or why. – dhasenan May 29 '17 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.