I'm trying to install kaa(IOT platform) on installing the dependencies getting an error on executing the command-

$ sudo systemctl start mongodb
error- Failed to start mongodb.service: Unit mongodb.service is masked.
  • Ha I decided to make it an answer ;-) – Rinzwind May 26 '17 at 11:34
up vote 22 down vote accepted

Unit mongodb.service is masked.

So unmask it:

sudo systemctl unmask mongodb
  • 1
    I also received this error after installing mongodb-org. Why was it masked by default? What does that mean to be masked? – Cerin Feb 6 at 18:24
  • 1
    @Cerin you downvoted? Please see askubuntu.com/questions/710420/… on what masked is. And to the why.... it means disabled, maybe because nobody wants mongodb enabled by default. – Rinzwind Feb 6 at 18:41

With 3+ version of mongodb. You dont have to start mongodb but you just have to start mongod. So proper way to start mongod will be

sudo systemctl start mongod

  • 1
    Failed to start mongod.service: Unit mongod.service not found. Change mongod to mongodb and hte result is Failed to start mongodb.service: Unit mongodb.service is masked. – Craig Hicks Jun 10 at 17:06

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.