1

I am always stuck at the following error. I use ubuntu version 16.10

Ign:7 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main amd64 Packages
Ign:8 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main i386 Packages
Ign:9 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main all Packages
Ign:10 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main Translation-en
Ign:11 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main Translation-en_IN
Ign:12 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main amd64 DEP-11 Metadata
Ign:13 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main all DEP-11 Metadata
Ign:14 http://ppa.launchpad.net/upubuntu-com/web/ubuntu yakkety/main DEP-11 64x64 Icons
0% [Waiting for headers] [Waiting for headers]

Please help. I have already check for other answer with no luck.

4
  • 2
    Welcome to Ask Ubuntu! Ubuntu 16.10 is not the latest LTS version and you should upgrade to Ubuntu 17.04.
    – fosslinux
    May 26, 2017 at 4:16
  • 3
    17.04 is NOT an LTS release. This may be a silly question but are you connected to the Internet? e.g. ping ppa.launchpad.net or see if ppa.launchpad.net/upubuntu-com/web/ubuntu comes up in your browser. I'm assuming, perhaps incorrectly, that the repos you are trying to load and current and active.
    – jones0610
    May 26, 2017 at 4:25
  • Please check your internet connection! DO as jones said... May 26, 2017 at 4:51
  • @jones0610, this may be a silly question but for those who may not be using Ubuntu regularly. May 26, 2017 at 5:29

2 Answers 2

4

Just got out of this issue after spending 5 hours trying to figure out what was wrong. It is either your mirror through which Ubuntu is accessing packages or your service provider is blocking something. I would recommend:

  1. Check if the current server that you're using is accessible through the browser. If it's not, use another mirror. Go to 'Software & Updates' and choose a mirror from among the ones available at 'Download from'.
  2. Check the sources.list file in /etc/apt/ and comment out all the lines that access packages from the mirror that wasn't reachable.

If changing mirror doesn't work, check if you are able to get things updated using sudo apt-get update after you connect to a different ISP. Probably try with your phone's hotspot? Might just work. (Worked for me.)

1
  • Using another network solved the problem for me :) Still need to figure out which source caused the problem though. Thanks!
    – stemadsen
    Aug 19, 2019 at 11:08
1

I'll try one more time to leave some comments about this issue on this forum. It is to help others, so think twice before deleting it.

I started seeing this problem on a VM running xenial , on which I had not changed any config for some time before the issue manifested.

I checked my sources.list and verified I could access the repo URLs using wget. e.g. wget archive.ubuntu.com/ubuntu/

This worked fine. So I could rule out firewall or network issues connecting to the repo hosts.

I started tcpdump -i [ifname] host archive.ubuntu.com and could see traffic during wget, but nothing when I ran apt-get update.

I googled and found nothing helpful, so I'd like to leave this for people who might be in a similiar situation.

The point is you may have a proxy setup and not know it, as in my case. The ISP/datacentre hosting my VM had added it in my /etc/apt/apt.conf , and this proxy had evidently stopped working correctly.

If you're in a similiar situation you can see if , wittingly or unwittingly , you have a proxy set with

grep -r Proxy /etc/apt

In my case I removed the offending Proxy definition, and apt-get worked as expected once more.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.