1

I'm using ubuntu 16.04, but let's say i'm still kind of noobish on the subject.

I already had Mysql installed when I wanted to install MariaDB, and while it installed, it seems that MariaDB force uninstalled Mysql to take its place. However, when trying to launch the server, I have the following:

Configuring mariadb-server-10.1 (10.1.22-3) ...
Job for mariadb.service failed because a timeout was exceeded.
See "systemctl status mariadb.service" and "journalctl -xe" for details.
invoke-rc.d: initscript mysql, action "start" failed.
● mariadb.service - MariaDB database server
   Loaded: loaded (/lib/systemd/system/mariadb.service; enabled; vendor preset: enabled)
   Active: failed (Result: timeout) since Fri 2017-05-26 00:52:18 CEST; 11ms ago
  Process: 14410 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 14320 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SUCCESS)
  Process: 14316 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 14314 ExecStartPre=/usr/bin/install -m 755 -o mysql -g root -d /var/run/mysqld (code=exited, status=0/SUCCESS)
 Main PID: 14410 (code=exited, status=0/SUCCESS)

mai 26 00:50:45 jaeger767-OMEN systemd[1]: Starting MariaDB database server...
mai 26 00:50:46 jaeger767-OMEN mysqld[14410]: 2017-05-26  0:50:46 140701379916352 [Note] /usr/sbin/mysqld (mysqld 10.1.22-MariaDB-) starting as process 14410 ...
mai 26 00:52:16 jaeger767-OMEN systemd[1]: mariadb.service: Start operation timed out. Terminating.
mai 26 00:52:18 jaeger767-OMEN systemd[1]: Failed to start MariaDB database server.
mai 26 00:52:18 jaeger767-OMEN systemd[1]: mariadb.service: Unit entered failed state.
mai 26 00:52:18 jaeger767-OMEN systemd[1]: mariadb.service: Failed with result 'timeout'.
dpkg: 
Package processing error mariadb-server-10.1 (--configure) : the under-process script post-installation returned an exit error code 1

Now I can't uninstall MariaDB without Ubuntu wanting to configure it, and I don't know how to fix this, I found some stuff about this on StackExchange, but it didn't work

Thank you in advance

5

1 Answer 1

4

Like ChrisAga stated it in the comments:

See : askubuntu.com/questions/750604/… Explanation of the issue and how to solve it.

This is an AppArmor issue that can be fixed by configuring AppArmor to only complain about the mysqld process.

Here's a summary of the commands of the accepted answer in that link.

sudo apt-get install apparmor-utils
sudo aa-complain /usr/sbin/mysqld
sudo service apparmor reload
sudo systemctl start mariadb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.