5

I am able to connect to wifi networks that don't require password. But when I try to connect to a network that requires password, the password is not asked, Network Manager just tries to connect and of course it fails.

This is the log from /var/log/syslog:

NetworkManager[936]: <info>  [1495625898.1943] device (wlp2s0): Activation: starting connection 'true_home2G_b68' (ea2f25dd-98bd-4e72-b660-5ac56c683519)
NetworkManager[936]: <info>  [1495625898.1944] audit: op="connection-activate" uuid="ea2f25dd-98bd-4e72-b660-5ac56c683519" name="true_home2G_b68" pid=2168 uid=1000 result="success"
NetworkManager[936]: <info>  [1495625898.1945] device (wlp2s0): state change: disconnected -> prepare (reason 'none') [30 40 0]
NetworkManager[936]: <info>  [1495625898.1946] manager: NetworkManager state is now CONNECTING
NetworkManager[936]: <info>  [1495625898.1951] device (wlp2s0): state change: prepare -> config (reason 'none') [40 50 0]
NetworkManager[936]: <info>  [1495625898.1953] device (wlp2s0): Activation: (wifi) access point 'true_home2G_b68' has security, but secrets are required.
NetworkManager[936]: <info>  [1495625898.1953] device (wlp2s0): state change: config -> need-auth (reason 'none') [50 60 0]
NetworkManager[936]: <warn>  [1495625923.2170] device (wlp2s0): No agents were available for this request.
NetworkManager[936]: <info>  [1495625923.2171] device (wlp2s0): state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
gnome-session[1940]: (nm-applet:2168): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
NetworkManager[936]: <info>  [1495625923.2174] manager: NetworkManager state is now DISCONNECTED
NetworkManager[936]: <warn>  [1495625923.2184] device (wlp2s0): Activation: failed for connection 'true_home2G_b68'
NetworkManager[936]: <info>  [1495625923.2199] device (wlp2s0): state change: failed -> disconnected (reason 'none') [120 30 0]
kernel: [32456.473864] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready

I don't know if it matters, I think this problem started after installation of anbox. After that, in ifconfig results, wlp2s0 was replaced by another entry (anboxlo if I remember correctly). Now I removed anbox and tried to put back the old settings, searched for the errors in output... but no success.

Please help me here. I will be available to give more information as required.


EDIT 1 to add information required by @George in comment:

Result of $ less /var/log/syslog | grep -i wpa:

May 28 15:11:25 dv-XPS-15-9550 dbus[888]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
May 28 15:11:25 dv-XPS-15-9550 systemd[1]: Starting WPA supplicant...
May 28 15:11:25 dv-XPS-15-9550 dbus[888]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
May 28 15:11:25 dv-XPS-15-9550 systemd[1]: Started WPA supplicant.
May 28 15:11:25 dv-XPS-15-9550 wpa_supplicant[2633]: Successfully initialized wpa_supplicant
May 28 15:11:25 dv-XPS-15-9550 NetworkManager[2619]: <info>  [1495977085.7349] supplicant: wpa_supplicant running
May 28 15:11:25 dv-XPS-15-9550 wpa_supplicant[2633]: dbus: wpa_dbus_get_object_properties: failed to get object properties: (none) none
May 28 15:11:25 dv-XPS-15-9550 wpa_supplicant[2633]: dbus: Failed to construct signal
May 28 15:11:25 dv-XPS-15-9550 wpa_supplicant[2633]: Could not read interface p2p-dev-wlp2s0 flags: No such device
May 28 15:11:33 dv-XPS-15-9550 wpa_supplicant[2633]: p2p-dev-wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
May 28 15:13:07 dv-XPS-15-9550 wpa_supplicant[2633]: nl80211: deinit ifname=p2p-dev-wlp2s0 disabled_11b_rates=0
May 28 15:13:07 dv-XPS-15-9550 wpa_supplicant[2633]: nl80211: deinit ifname=wlp2s0 disabled_11b_rates=0
May 28 15:13:24 dv-XPS-15-9550 NetworkManager[2755]: <info>  [1495977204.9381] supplicant: wpa_supplicant running
May 28 15:13:24 dv-XPS-15-9550 wpa_supplicant[2633]: dbus: wpa_dbus_get_object_properties: failed to get object properties: (none) none
May 28 15:13:24 dv-XPS-15-9550 wpa_supplicant[2633]: dbus: Failed to construct signal
May 28 15:13:24 dv-XPS-15-9550 wpa_supplicant[2633]: Failed to create interface p2p-dev-wlp2s0: -16 (Device or resource busy)
May 28 15:13:24 dv-XPS-15-9550 wpa_supplicant[2633]: nl80211: Failed to create a P2P Device interface p2p-dev-wlp2s0
May 28 15:13:24 dv-XPS-15-9550 wpa_supplicant[2633]: P2P: Failed to enable P2P Device interface

(Network Manager seems to not be running after system boot. I run these commands: $ sudo service network-manager restart at 15:11:25, $ sudo service network-manager stop at 15:13:07 and $ sudo service network-manager start at 15:13:24)


EDIT 2 for more requested information:

$ sudo systemctl list-unit-files --type=service | grep enabled

accounts-daemon.service                    enabled 
anacron-resume.service                     enabled 
anacron.service                            enabled 
autovt@.service                            enabled 
avahi-daemon.service                       enabled 
bluetooth.service                          enabled 
brltty.service                             enabled 
cron.service                               enabled 
cups-browsed.service                       enabled 
cups.service                               enabled 
dbus-org.bluez.service                     enabled 
dbus-org.freedesktop.Avahi.service         enabled 
dbus-org.freedesktop.ModemManager1.service enabled 
dbus-org.freedesktop.thermald.service      enabled 
display-manager.service                    enabled 
dns-clean.service                          enabled 
friendly-recovery.service                  enabled 
getty@.service                             enabled 
gpu-manager.service                        enabled 
lightdm.service                            enabled 
mariadb.service                            enabled 
ModemManager.service                       enabled 
mysql.service                              enabled 
mysqld.service                             enabled 
networking.service                         enabled 
NetworkManager-wait-online.service         enabled 
pppd-dns.service                           enabled 
resolvconf.service                         enabled 
rsyslog.service                            enabled 
snapd.autoimport.service                   enabled 
snapd.service                              enabled 
snapd.system-shutdown.service              enabled 
syslog.service                             enabled 
systemd-timesyncd.service                  enabled 
thermald.service                           enabled 
ufw.service                                enabled 
unattended-upgrades.service                enabled 
ureadahead.service                         enabled 
whoopsie.service                           enabled

$ iw list | grep -i p2p

 * P2P-client
 * P2P-GO
 * P2P-device
 * start_p2p_device
 * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
 * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
 * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
 * P2P-client: 0x40 0xd0
 * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
 * P2P-device: 0x40 0xd0
 * #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
 * #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,

EDIT 3 after enabling Network Manager service:

$ sudo systemctl list-unit-files --type=service | grep enabled
accounts-daemon.service                    enabled 
anacron-resume.service                     enabled 
anacron.service                            enabled 
autovt@.service                            enabled 
avahi-daemon.service                       enabled 
bluetooth.service                          enabled 
brltty.service                             enabled 
cron.service                               enabled 
cups-browsed.service                       enabled 
cups.service                               enabled 
dbus-org.bluez.service                     enabled 
dbus-org.freedesktop.Avahi.service         enabled 
dbus-org.freedesktop.ModemManager1.service enabled 
dbus-org.freedesktop.nm-dispatcher.service enabled 
dbus-org.freedesktop.thermald.service      enabled 
display-manager.service                    enabled 
dns-clean.service                          enabled 
friendly-recovery.service                  enabled 
getty@.service                             enabled 
gpu-manager.service                        enabled 
lightdm.service                            enabled 
mariadb.service                            enabled 
ModemManager.service                       enabled 
mysql.service                              enabled 
mysqld.service                             enabled 
network-manager.service                    enabled 
networking.service                         enabled 
NetworkManager-dispatcher.service          enabled 
NetworkManager-wait-online.service         enabled 
NetworkManager.service                     enabled 
pppd-dns.service                           enabled 
resolvconf.service                         enabled 
rsyslog.service                            enabled 
snapd.autoimport.service                   enabled 
snapd.service                              enabled 
snapd.system-shutdown.service              enabled 
syslog.service                             enabled 
systemd-timesyncd.service                  enabled 
thermald.service                           enabled 
ufw.service                                enabled 
unattended-upgrades.service                enabled 
ureadahead.service                         enabled 
whoopsie.service                           enabled

$ iw list | grep -i p2p (same)

Also let me add that now when I try to connect to a wifi with password I get this error message in popup:

Connection failure

Connection activation failed

(2) Active connection removed before it was initialized

  • 1
    Please run less /var/log/syslog | grep -i wpa and post any results – George Udosen May 28 '17 at 12:27
  • 1
    Also post this: sudo systemctl list-unit-files --type=service | grep enabled – George Udosen May 28 '17 at 13:56
  • 1
    Also add this: iw list | grep -i p2p – George Udosen May 28 '17 at 13:59
  • 1
    I've searched for more info about first error, then I got here and from reply #20 I got here. It mentions my laptop, XPS-15-9550 and recommends to update BIOS. I suppose it wont harm to do it... Ops, now I saw your last two comments, I will proceed as you requested. – dxvargas May 28 '17 at 13:59
  • 1
    Your NetworkManager.service doesn't appear to be enabled, Please enable with sudo systemctl start NetworkManager, then sudo systemctl enable NetworkManager – George Udosen May 28 '17 at 14:16
0

the keyring daemon is probably not running. you can check if it is enabled in autostart applications, look for "Gnome keyring"

also, i think consolekit should be running as a service

  • I've checked, keyring is running ($ ps aux | grep keyring). Information I've got (like here) for consolekit is that it isn't neither required nor very trustful. – dxvargas May 28 '17 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.