I can successfully visit my website hosted on a VPS by entering in the custom domain name I purchased. However, when the site loads in the browser I still see the IP address of my VPS instead of my domain name. I can't quite figure out what I need to do. I've set up both an A Record and a CNAME on my VPS. I have Apache installed. I've tried a number of fixes and I'm not sure what else to do

I fixed the problem. It had to do with my installation of Wordpress. Under Settings - General I needed to set my WordPress Address (URL) to my IP and Site Address (URL) to my custom domain name

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.