6

I do not know how it comes, but my calendar(upper right corner) is in Polish. How to change this to English?

2
  • only that text is affected and all the other text is in English? – Sumeet Deshmukh May 24 '17 at 14:48
  • @SumeetDeshmukh Yes,everything else is in English. – MikiBelavista May 24 '17 at 14:59
2

data utility uses variable LC_TIME to know what language of days to use. If you want to know if this is really the issue, try:

echo $LC_TIME

then if you dont want to mess up anything, but still have different language in your script just change it in your script like

LC_TIME=en_US.utf8
2
  • as said in the other answer, the file in question is /etc/default/locale. – cipricus Mar 11 '20 at 15:59
  • just to clarify, if you want to change it permanently, export LC_TIME=en_US.utf8 ...put it into ~/.bashrc (your shell's init file) or ~/.profile to apply it everywhere on start – Viktor Nagy Jun 5 '20 at 9:33
6

If everything except date is in English, then there is a high chance that the value of LC_TIME is something wrong, use localectl command to change it to your desired locale:

sudo localectl set-locale LC_TIME=en_US.utf8

or en_GB.utf8 for UK.

You can also place LC_TIME=en_US.utf8 at this file /etc/default/locale manually if you wish.

1

The default locale file location here: /etc/default

First install: nautilus-admin then logOut and logIn.

Then go to /etc/default.

Right click on locale and Edit As Administrator.

Edit locale file like this and save:

#  File generated by update-locale
LANG="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"

Done. Now log-out and log-in.

0

Select the system settings "window". Click on Language Support. In the Regional Format tab set the preferred language. I had same problem when I first set clock wound up in Spanish. You will need to restart after change to take affect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.