1

I am pulling my hair over this issue: my guest VM registers OK with my router and can access the Internet, but neither the router, host or any LAN computer can even ping the guest

Network: TPLink Router + Host running Ubunter Server 15 with Guest running Windows Server 2012 + Other PCs

I followed this guide and read in forums that the bridge should solve everything, I made sure that the guest firewall takes pings (and it can ping itself) and yet the problem persists.

Any ideas?

Host ifconfig:

br0       Link encap:Ethernet  HWaddr d4:ae:52:d3:a3:fb
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::d6ae:52ff:fed3:a3fb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:75546 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67338 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:9073123 (9.0 MB)  TX bytes:13915784 (13.9 MB)

eno1      Link encap:Ethernet  HWaddr d4:ae:52:d3:a3:fb
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:130010 errors:0 dropped:86 overruns:0 frame:0
          TX packets:76756 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:37807268 (37.8 MB)  TX bytes:15209842 (15.2 MB)
          Interrupt:16

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:380 errors:0 dropped:0 overruns:0 frame:0
          TX packets:380 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:22800 (22.8 KB)  TX bytes:22800 (22.8 KB)

vnet0     Link encap:Ethernet  HWaddr fe:54:00:3c:52:2a
          inet6 addr: fe80::fc54:ff:fe3c:522a/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7664 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18717 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:836769 (836.7 KB)  TX bytes:12182959 (12.1 MB)

Guest ipconfig Ethernet adapter (abridged)

Connection-specific DNS Suffix : home
Description : Realtek + Fast Ethernet NIC
Physical Address: 52-54-00-xx-xx-xx
DHCP Enabled: Yes
Autoconfiguration Enabled: Yes
Link-local IPv6 Address: xxxx
IPv4 Address: 192.168.1.3(Preferred)
Default Gateway: 192.168.1.1
DHCP Server: 192.168.1.1
DNS Servers: 192.168.1.1

Host \etc\network\interfaces:

auto lo
iface lo inet loopback

auto eno1
iface eno1 inet manual

auto br0
iface br0 inet dhcp
bridge_ports eno1
bridge_fd 9
bridge_hello 2
bridge_maxage 12
bridge_stp off
  • Maybe the guest is set to ignore pings? When you try to ping it from the host, does arp show that it found the guest's IP address? – psusi May 25 '17 at 1:48
  • Thanks for suggesting arp -- it shows the guest's IP address: 192.168.1.3 ether 52:54:00:3c:52:2a C br0 – phaedo May 25 '17 at 4:14
  • The guest can ping itself from the command line, and I added a firewall rule to allow pings... – phaedo May 25 '17 at 4:16
  • Thank you for pointing to the firewall issue, I resolved the problem: explanation below – phaedo May 25 '17 at 12:39
1

Issue resolved! As pointed out by @psusi this was a (slightly tricky) firewall issue. The problem was the following: Windows Server firewall distinguishes between three network types: private, domain, public

As you might have guessed, the guest firewall rule I had created to allow pings was assigned to private by default, whereas the Ethernet adapter was automatically made a public network. Therefore, the firewall was blocking all pings (except those made on the guest itself).

Solutions:

  1. Add public profile to all relevant firewall rules in the Windows Firewall (in Properties > Advanced tab), OR:
  2. Change network type to private (see this link )

I hope this helps anyone confronted to a similar problem in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.