63

I've just upgraded to Ubuntu 17.04, using the GNOME desktop. Suddenly, I've started seeing 'printer added' notifications as OSD popups - approximately every 2 minutes! It's really distracting.

Anyone have any idea how I can either stop them at source, or at the very least filter them out from the OSD notifications?

3
  • 1
    This is a problem for me as well in Ubuntu 17.10. I've reported a bug here: bugs.launchpad.net/ubuntu/+bug/1725955
    – Gustav
    Oct 22, 2017 at 10:10
  • Never had the problem until 20.04, which is addressed by @jimsmith solution.
    – Déjà vu
    Jul 13, 2021 at 4:27
  • I have this problem in Ubuntu 20. It's annoying when I'm trying to use the computer as a slideshow server. Jan 24 at 19:21

5 Answers 5

51

The problem that you're identifying appears identical to my case, which is, that upon OS restart, the system goes through an auto-discovery/auto-install process, and then politely notifies the user via a notification window (the OSD, or on-screen display). Yet then--periodically--this process seems to repeat itself for some as yet unknown reason.

Seems to me that somewhere in the new 17.04 driverless printer driver discovery logic, something is broken. The best I can tell is that the colord daemon is failing on a missing ICC file for the printer in question, which causes CUPS to want to "reinstall" the printer driver, and hence the repeating "printer installed" OSD message. Perhaps as a clue, when installing a "non-driverless" printer driver, the corresponding ICC is installed correctly.

In my own case, I've solved the problem by preventing CUPS from initiating this auto-everything process entirely. In this way, I install my printer(s) once, and never see a "printer added" OSD messages again.

The solution:

  • Edit /etc/cups/cups-browsed.conf, changing the BrowseRemoteProtocols CUPS dnssd line to BrowseRemoteProtocols none

  • Restart CUPS from Terminal service cups restart

Note that this assumes your printer(s) are on a LAN and not directly connected to your machine. If your printer is local (physically attached), you may want to edit BrowseProtocols instead (untested).

A restart of the CUPS service or machine reboot should resolve the "printer added" issue. Note that you'll need to manually add your printer(s), as the auto-discovery feature has now been disabled.

CUPS Reference: https://www.systutorials.com/docs/linux/man/5-cups-browsed.conf/

Rich

6
  • that sounds pretty plausible. My printer is indeed on the network. I'm not in the office today, but I'll try your suggestion next time I am. Thanks! Jun 2, 2017 at 12:47
  • 22
    For me the configuration file was /etc/cups/cups-browsed.conf
    – gitaarik
    Jul 28, 2017 at 15:49
  • 3
    I do not care if the underlying process repeats. I just want to avoid seeing the OSD messages. Can those be disabled? Nov 2, 2017 at 10:25
  • 1
    Does not work in 17.10. I still get the notifications, and printer gets added, as a duplicate to a previously installed printer. Nov 6, 2017 at 17:29
  • 1
    This stops remote printers from being installed. I just want the notification to stop. Nov 1, 2020 at 22:45
21

So I thought I had found a solution (via FedoraForums actually):

# Finding the schemas of interest:
$ gsettings list-schemas | grep -i notif

# Listing the values to target:
$ gsettings list-recursively org.gnome.settings-daemon.plugins.print-notifications

# Changing the value:
$ gsettings set org.gnome.settings-daemon.plugins.print-notifications active false

Source http://www.fedoraforum.org/forum/showthread.php?t=297053

Unfortunately, despite a brief pause, I'm still getting OSD notifications.

6
  • 2
    works like a charm on 17.10
    – R13e
    Jan 11, 2018 at 8:05
  • 1
    Seems to do the trick on Debian 9. Probably a Gnome issue.
    – kabanus
    Apr 12, 2018 at 7:08
  • 7
    I like this answer because it demonstrates how to find the setting that needs to be changed, rather than just giving the fix. Plus you change the notification setting rather than turning off printer auto-detection altogether. Aug 15, 2018 at 12:51
  • 2
    It doesn't help my Ubuntu 18.04 either.
    – Samuel Li
    Feb 26, 2019 at 22:42
  • 3
    It doesn't work on 20.04, for me at least.
    – psiphi75
    Jul 22, 2020 at 23:08
17

Follow these steps:

  1. Go to Settings
  2. Click Notifications on the Sidebar
  3. Click Printers under Applications
  4. Turn Off the Notification Toggle
3
  • 1
    This comment is God's work :)! May 4 at 11:31
  • This makes me happy! @AnimeshKarnewar
    – Wangwe
    May 15 at 14:49
  • I think this is a feature of later versions of Ubuntu, which does not require to edit the configuration file manually. Great!
    – berkus
    May 22 at 6:58
9

You need to stop dns-sd from constantly scanning in cups configuration:

Ubuntu 20.04:

edit /etc/cups/cups-browsed.conf and

change:

BrowseRemoteProtocols dnssd cups 

to:

BrowseRemoteProtocols cups

Restart:

sudo systemctl restart cups
4
  • running ubuntu 20 - will give this a shot! Jun 22, 2021 at 19:06
  • Work in 20.04..
    – Déjà vu
    Jul 13, 2021 at 4:29
  • I think this is working (Ubuntu 20 for me too). Jan 25 at 3:26
  • pkill gjs to get rid of the current notifications so I can enjoy my video playlist on my kiosk mode VLC monitor. Apr 30 at 19:33
0

I had the same problem with regular annoying printer added notifications. In my case, the root cause appeared to be the same as identified by richbl; missing colour profiles. I installed the missing colour profiles and the problem went away:

sudo apt update
sudo apt install icc-profiles
sudo systemctl restart cups
1
  • 1
    Didn't work for me on Ubuntu 20.04 - I just got another random "Printer added" notification. 😫
    – dw1
    Sep 20, 2020 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.