0

I'm using GNOME Shell 3.14.4 I've created an alias to be able to launch my eclipse with different workspace (without tieing it to the terminal) using the following alias in my .bash_aliases file:

alias eMyProject='nohup ~/eclipse/eclipse -data /opt/workspaces/myProject/'

This work great, however when I Alt / Tab to switch between Eclipse, the Eclipse Windows show as ungrouped and all are name eclipse. Even though the window name is set to be the workspace name and correctly shows myProject.

enter image description here

How can I do it so that instead of Eclipse it shows the window name : myProject ? Gnome settings, Eclipse settings, alias modification, anything working would be great.

0

If you don't mind all of the windows being ungrouped then you can cycle through all of the windows by tapping (hit and release) the [Super] key then tapping the [Alt] key.

Thumbnails of all of your windows will appear and you can use [Tab] to move between them. I'm using Ubuntu 17.04 with Gnome Shell 3.24.1, since your version is slightly older YMMV.

ungrouped-tab-between-all-windows

1
  • Just noticed this is the same view you get when you click on the "Activities" menu in gnome, just activated from the keyboard. – M. Krajnak May 29 '17 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.