I was trying to install some packages referring to this documentation:http://wiki.friendlyarm.com/wiki/index.php/NanoPi_M1#Make_Your_Own_Debian


 sudo apt-get install libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386<br/>

The first two line were succefully installed
When i try to run the third line,the result was this:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.6)
                        Recommends: libgl1-mesa-dri:i386 (>= 7.2)
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I am running ubuntu 14.04-64bit
Can i solve this


I got a similar problem, an pkgProblemResolver error when I was trying to install openssh-server.

The problem may be caused by (1) "hold packages" which installation resulted in error and the dependencies (i.e. other packages) in your system are corrupted or missed, or (2) by incompatibilities of the packages you want to install and the packages you already have.

If it is a problem with hold packages, you can detect the hold packages and remove or unhold them.

  1. You can determine the hold packages using dpkg --get-selections

    $ dpkg --get-selections | grep hold
    $ apt-mark showhold
  2. Then, you can un-mark or remove the hold packages

    $ sudo apt-mark unhold package_name
    $ sudo apt-get --purge remove package_name
  3. Finally, I recommend to auto-remove unused packages

    $ sudo apt-get autoremove

If it is a problem with dependencies, The solution may involve removing and downgrading some of the packages you already have. You may use aptitude to get suggestions on how to solve the problem.

  1. First, you must install aptitude if you do not have it

    $ sudo apt-get install aptitude
  2. Then, you can run the command indicating that you want to install the openssh-server

    $ sudo aptitude install libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386
  3. The program will show you suggestions about how to solve the problem. Usually the first solution does not work. You can press n to request a new suggestion. Press y to accept a solution that installs the openssh-server and downgrades some other packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.