1

I know there are already a few questions like this relating to steam not being able to load a specific 32-bit library, or maybe a few others, but I'm getting something a little bit different, I think:

You are missing the following 32-bit libraries, and Steam may not run:

libvideo.so
libXtst.so.6
libXrandr.so.2
libgobject-2.0.so.0
libgtk-x11-2.0.so.0
libpulse.so.0
libgdk_pixbuf-2.0.so.0
libicui18n.so

So, earlier today I accidentally tried to start steam without mounting a hard drive where some steam games are installed, and it got hung up trying to launch. I closed steam and mounted the drive, then tried to restart it. It seemed to launch like normal, and proceeded to download steam updates as expected. But right after that was done, this error popped up.

I have tried to look around for some way to fix this and haven't found something that worked for me. This error message has persisted even after removing and reinstalling steam. I might have done this wrong as I'm very new to Linux and Ubuntu (and in the middle of transitioning from Windows 10), but I've also tried using the "sudo apt-get install (all the library names)" in the terminal and it did nothing to get rid of this error. I'm unsure what else I can try to do to fix this on my own...

  • If it complains about not having 32-bit libraries and your OS is 64-bit then perhaps you need to do sudo dpkg --add-architecture i386. Of course, right after that do the usual sudo apt-get updateand sudo apt-get upgrade. – user692175 May 24 '17 at 7:41
  • I'm afraid this didn't do a thing. Like I said, Steam was working perfectly fine before I attempted to launch it without all of my drives mounted. I don't see how I would have actually lost all the files required to run the software. – DJTHED May 26 '17 at 7:49
0

Okay, before when I said in my question when I uninstalled Steam, apparently I didn't do THAT part right. Removing it with the Ubuntu Software app doesn't get rid of everything. I looked up a way to uninstall Steam in its entirety and found this:

sudo apt-get remove steam
sudo apt-get purge steam
rm -rf ~/.local/share/Steam && rm -rf ~/.steam

After applying all that, I reinstalled Steam and it works just fine.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.