1

I recently reformatted my laptop. Beforehand I backed up all my data on a external hdd. Before doing this, I completely reformatted my external hdd using the Disk Manager and created a new Linux Filesystem partition. I then moved all data on to the hdd. I had no problems mounting or accessing files on the hdd. However, after reformatting the laptop and reinstalling Ubuntu I can no longer mount the hdd.

Output fdisk -l

Disk /dev/sdb: 698,7 GiB, 750156374016 bytes, 1465149168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 33553920 bytes
Disklabel type: gpt
Disk identifier: 00007F4F-6548-0000-8534-0000C2310000

Device     Start        End    Sectors   Size Type
/dev/sdb1   2048 1465149134 1465147087 698,7G Linux filesystem

Output parted:

Model: APPLE HD D HTS547575A9E38 (scsi)
Disk /dev/sdb: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name  Flags
 1      1049kB  750GB  750GB

Update: This is what happens when I try to mount

$ sudo mount /dev/sdb1 mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error

   In some cases useful info is found in syslog - try
   dmesg | tail or so.

@9291Sam Yes, I meant GNOME Disks

  • What happens when you try to mount it? How are you doing that? Any error messages? – user692175 May 23 '17 at 20:06
  • How did you make a Linux filesystem partition from Microsoft windows Disk manager – 9291Sam May 23 '17 at 22:37
  • 1
    @9291Sam, he didn't say Windows... I'm sure he meant the Gnome Disk manager. – psusi May 23 '17 at 23:37
  • This is what happens when I try to mount it: $ sudo mount /dev/sdb1 mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so. @9291Sam Yes, I meant GNOME Disks – a p May 24 '17 at 23:09
2

Try the syntax

sudo mount -t ext4 /dev/sdb1 /mnt

assuming the filesystem is ext4

  • Output: mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so. – a p May 25 '17 at 20:02
  • That sounds bad. – Organic Marble May 25 '17 at 20:03
  • Nothing that can be done? – a p May 25 '17 at 21:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.