0

Last week I have decided to installed ubuntu on my computer while keeping windows 7. After I have installations, during the start up my mouse, printer, and usb driver is not detected. They are being detected after I restart windows 7 twice. My computer is Lenovo lenovo y50-70.

I know the issue is being cause by bios settings, something to do with usb settings maybe, but I do not know. So do you what bios settings shoud I use to fix this issue? Or there is something else is causing the problem? Thanks.

Screenshots of my bios settings: enter image description here enter image description here enter image description here enter image description here

terminal output of lsusb

Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 003 Device 003: ID 8087:07dc Intel Corp. 
Bus 003 Device 002: ID 174f:14b8 Syntek 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • What is "usb driver"? In terminal what is the output of lsusb? Review your BIOS and look for USB setting something like legacy/compatible/usb2/usb3/etc. Let me know what the choices are. Have you checked the Lenovo web site for BIOS updates? – heynnema May 23 '17 at 19:11
  • Hi heynnema, I have added screenshots of my bios settings and terminal output of lsusb. So what do you think is wrong? Thanks for your help btw. – mertimiks May 25 '17 at 20:52
  • You might try changing the "Always on USB" to enabled and see if that helps. Otherwise everything else looks ok to me. Do you have the mouse/printer plugged directly into a USB port on the computer, or via a hub? – heynnema May 25 '17 at 23:20
  • I changed to always on USB option, issue persists. I plug mouse via from usb port. – mertimiks May 28 '17 at 9:53
  • I'm out of ideas. Sorry. – heynnema May 28 '17 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.