Recently I have installed an older version of Ubuntu on my old machine. Whenever I try to install any software, I get an error saying it couldn't be found:

$ sudo apt-get install vlc
Reading package lists... Done               
Building dependency tree       
Reading state information... Done    
E: Couldn't find package vlc
  • 9
    It might be worth editing some (or all) answers to this question, as during the weekend after spending quite a while trying to make this work I have by luck realized that they have moved over from http://old-releases.ubuntu.com/ubuntu/ to http://us.archive.ubuntu.com/ubuntu/ (or your own respective two letter abbreviated county code at the beginning) starting from 17.10 (essentially in sync with going back to the beginning of the alphabet).
    – Isti115
    Commented May 6, 2019 at 22:22
  • 1
    They deliberately do this in order to break older releases and force you to upgrade
    – Matej J
    Commented Jun 11, 2020 at 21:11
  • 1
    Upgrading from Artful to Bionic in 2020, I found that us.archive. did not work, but old-releases. did.
    – jab
    Commented Sep 19, 2020 at 19:28
  • Try to upgrade your release, e.g. sudo do-release-upgrade.
    – kenorb
    Commented Oct 3, 2020 at 20:09
  • 2
    Upgrading EOL Ubuntu 21.10 to 22.04 I upgraded Ubuntu using the GUI program "Software Updater" in a simpler way without manually updating any of the system file as suggested by the earlier responses in this post. That too many months after EOL of Ubuntu 21.10. Note: The procedure given in ubuntu.com/tutorials/… throw an error "404 Not Found" mostly because my /etc/apt/sources.list was referring to the defunct links. Whereas, the GUI approach approached successfully.
    – Bhuvan
    Commented Dec 28, 2022 at 14:10

12 Answers 12


The repositories for older releases that are not supported (like 11.04, 11.10 and 13.04) get moved to an archive server. There are repositories available at http://old-releases.ubuntu.com.

The reason for this is that it is now out of support and no longer receiving updates and security patches.

I would urge you to consider a supported distribution. If your computer is too old in terms of memory or processor then you should consider a distribution such as Lubuntu or Xubuntu.

If you want to continue using an outdated release then edit /etc/apt/sources.list and change archive.ubuntu.com and security.ubuntu.com to old-releases.ubuntu.com.

You can do this with sed:

sudo sed -i -re 's/([a-z]{2}\.)?archive.ubuntu.com|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

then update with:

sudo apt-get update && sudo apt-get dist-upgrade

Sometimes, it might be faster to create backups of your system and reinstall using supported release instead.

Source: Can I keep using Ubuntu 9.04 if it's outdated?

To upgrade to a new release:

Once you have performed the above steps to switch to the old-releases mirrors, update the Update Manager and then do do-release-upgrade:

sudo apt-get update
sudo apt-get install ubuntu-release-upgrader-core
sudo do-release-upgrade

See also EOLUpgrades - Community Help Wiki.

  • 12
    and, just for the sake of completeness... what about extras repository (for Skype etc)? Are they available anywhere after EOF?
    – MestreLion
    Commented Apr 27, 2013 at 1:00
  • 5
    an easier way is sudo vi /etc/apt/sources.list and modify it manually. I had to do it because I'm quite new and I don't know sed to make this work for karmic, Thanks, Your answer is still valid and correct.
    – JaDogg
    Commented Dec 3, 2013 at 19:08
  • 28
    An even easier way is sudo nano /etc/apt/sources.list, as vi* is just annoying...
    – Wilf
    Commented Mar 1, 2014 at 18:35
  • 5
    The sed command doesn't always work, as there are mirrors that are run by organizations outside of ubuntu.com. I'm not even sure that there are three dots for all of the domain names. For those, you must manually edit /etc/apt/sources.list.
    – Olathe
    Commented Jul 9, 2015 at 5:06
  • 3
    There is an issue with this in upgrading from 15.04 as of 3/21/17. Vivid is no longer supported, however the dist is not on old-releases. Commented Mar 21, 2017 at 20:07

What are 404 errors

The 404 or Not Found error message is a HTTP standard response code indicating that the client was able to communicate with the server, but the server could not find what was requested.

The web site hosting server will typically generate "404 - Page Not Found" web page, when users attempts to follow a broken or dead link.

Why are we facing 404 errors

Ubuntu follows the approach of two different release cycles:

Normal Ubuntu releases are supported for 9 months. LTS releases are supported for 5 years.

Past releases may have different support schedules (for example, normal releases (before 13.04) used to be supported for 18 months, while LTS releases (before 12.04) used to be supported for 3 years on the desktop and 5 years on the server).

EOL: Once the support period for a particular release is over; they are called End Of Life (EOL) and all the updates and package repositories for that Release are transferred to a different server which results in 404 errors while running sudo apt-get update. You can confirm if your release has become EOL by going to this page. If your Ubuntu release is mentioned under "End Of Life (EOL)" Table, then the release is no longer supported and you should try to upgrade to a newer supported release. However, if you wish to continue using this unsupported release, you would have to make necessary modifications in /etc/apt/sources.list to point to the old-releases server of Ubuntu.

Steps to make necessary modifications

  1. Open your Terminal:

    • Press Ctrl + Alt + T; OR
    • If you have Gnome: ApplicationsAccessoriesTerminal; OR
    • If you have Unity: press Super (the key between Left Ctrl and Left Alt) and query for Terminal.
  2. Run the following command to enter into root shell:

    sudo -i

    input your user password and press Enter. The prompt would change and would indicate that the root user is now logged in. Here run the following command:

    gedit /etc/apt/sources.list
  3. The file would open in a new Gedit window. Find the first line which doesn't start with #. Suppose you are running Karmic Koala (Ubuntu 9.10): it should be like the following line:

    deb <siteurl> karmic main restricted

    where, <siteurl> is your preferred server - http://gb.archive.ubuntu.com/ubuntu in your case (for example).

  4. Press Ctrl + H to replace your <siteurl> with http://old-releases.ubuntu.com/ubuntu.

    • Search for: http://gb.archive.ubuntu.com/ubuntu ie; <siteurl>
    • Replace with: http://old-releases.ubuntu.com/ubuntu and
    • Press Replace All
  5. Once again:

    • Search for: http://security.ubuntu.com/ubuntu (this exact url for all the Ubuntu Releases — whatever be the present server that you are using)
    • Replace with: http://old-releases.ubuntu.com/ubuntu
    • Press Replace All
  6. Save your file and exit Gedit.

  7. Run the following command to get out of root shell:


    You would find that the prompt switches back to indicate that your normal user is now logged in. Then run the following:

    sudo apt-get update

There you go. No 404 Errors this time. You can now install all the available packages for your Ubuntu Release. You can also run sudo apt-get dist-upgrade to install any Security/Bug-fix updates which have not yet been installed but you won't get any further Security/Bug-fix updates from Ubuntu.

  • 9
    +1 for also including instructions to update the security repo.
    – Gaffi
    Commented Mar 16, 2013 at 16:07
  • 3
    @Yokhen If the line didn't begin with deb <siteurl>, then most likely your /etc/apt/sources.list file has become corrupted due to some reason. Please follow the answers given at: How do I restore the default repositories?. That would restore the correct /etc/apt/sources.list for you and then follow my answer to change the servers to point to the old-releases server.
    – Aditya
    Commented Oct 24, 2014 at 8:15
  • 1
    In newer Ubuntu versions, gksu is no longer installed by default. And since the release would be EOL at this point, users won't be able to install it. It may be better to use nano or vim instead, with a normal sudo command. gksu may start causing confusion like in the following question: askubuntu.com/questions/797422/how-to-install-gksu-on-15-04
    – Dan
    Commented Jul 12, 2016 at 13:11
  • 1
    @Dan, modified the answer, now we enter into root shell and then run the graphical program. No need to use gksudo anymore. I want to keep this answer for the novice users like me and don't want to complicate matters with using terminal based editors, however easy or powerful they may be.
    – Aditya
    Commented Jul 17, 2016 at 13:56
  • 2
    @aderchox It's safe to manually edit sources.list. Just make sure to not make any mistake. And if apt complaints about any error, then fix the mistake and re-run the apt command :-)
    – Aditya
    Commented Jul 25, 2020 at 20:43

The short answer is to add the next apt repository to the Third-Party Software (or Other Software in newer versions) in Software Sources (or Software & Updates in newer versions):

deb http://old-releases.ubuntu.com/ubuntu code_name main restricted universe multiverse

The long answer...

GUI Method

Well, actually we will do this without using any terminal. Not even once. Just GUI, I promise ;-)

First, open Software Sources (or Software & Updates in newer versions). It does not matter how old your Ubuntu is, there is certainly something like this. For Ubuntu 9.04 (Jaunty Jackalope), look at next image to see where it's located:

Open Software Sources

After Software Sources (or Software & Updates) is open, go in Ubuntu Software and Updates tabs and unselect everything like in next pictures. You don't need these things anymore since your Ubuntu version is End of Life:

Ubuntu Software tab

enter image description here

Without closing Software Sources (or Software & Updates), go in Third-Party Software (for newest releases, this tab is named Other Software) tab and add a new apt repository. Insert exactly next line when you are asked:

deb http://old-releases.ubuntu.com/ubuntu jaunty main restricted universe multiverse

If your version of Ubuntu is not 9.04, replace in the above line jaunty with your Ubuntu codename (for example, if you have Ubuntu 9.10, replace it with karmic and so on):

Third-Party Software tab

Now, when you will close Software Sources (or Software & Updates), you will be asked to reload the information about available software. Just be sure that you have a working internet connection:

Reload available software

Downloading available software

And now, you are free to download almost whatever you want. For 9.04, you can use Synaptic Package Manager. For newest releases, there is Ubuntu Software Center.

For example, to install VLC in Ubuntu 9.04 using Synaptic Package Manager, follow the instructions in the following pictures:

Open Synaptic Package Manager

Search VLC in SPM

Mark VLC

Mark additional VLC

Apply VLC

Download VLC

Open VLC

If you want to Update your Ubuntu to a new release, just go to System > Update Manager:

Update Manager


I tested this method from a live session of Ubuntu 9.04 (Jaunty Jackalope) and as you can see from these pictures it worked. If you are on an installed session of Ubuntu, you will be asked sometimes for root or admin password. Just insert your personal user password when you are asked.

  • 2
    I just did all this from installed 10.10 (maverick) version. Everything well good as described. @Radu, your answer is flawless! Commented Aug 28, 2013 at 20:01
  • 2
    Those images needs updating... wait... what are you doing with a pre-12.04?
    – Braiam
    Commented Dec 30, 2013 at 14:01
  • 2
    @Braiam Those images are up to date. If you will give a try to Ubuntu 9.04 (Jaunty Jackalope), you will understand. Commented Mar 22, 2014 at 19:49
  • 2
    @RaduRădeanu Ubuntu 9.04 was my first foray into the linux world. Ahh, those screenshots bring back memories!
    – Tyzoid
    Commented Apr 13, 2014 at 22:03
  • Cannot get this to work for 15.04 to be upgraded to 16.04. Can't get past adding the new APT line please help.
    – MrMule
    Commented Oct 10, 2016 at 18:34

I got here since I could not upgrade a system from 15.10 (EOL) to 16.04. But none of the answers worked for me, even after doing everything that was suggested here I kept getting from sudo do-release-upgrade the annoying response:

Checking for a new Ubuntu release  
No new release found

And I had no success in running update-manager; it kept throwing exceptions which I could not resolve. I suspect something is corrupted in my 15.10 installation, but the bottom line is that the built-in upgrades just fail.

So I looked for a non-built-in method, and sure enough I found it looking at What does `do-release-upgrade` really do?.

Here is the solution that worked for me:

  1. Open http://changelogs.ubuntu.com/meta-release

  2. Locate the release you want to upgrade to. In my case it was Xenial Xerus (16.04 Long Term Support). You can find the corresponding codenames on Release - Ubuntu Wiki.

  3. Locate the UpgradeTool URL. For xenial it was http://archive.ubuntu.com/ubuntu/dists/xenial-updates/main/dist-upgrader-all/current/xenial.tar.gz. Download the tarball from that URL into an empty folder and and extract it.

  4. Locate the executable file with the same name as the distribution (in my case xenial). Run it with sudo:

    sudo ./xenial &
  5. Approve the upgrade, and wait for the download to complete - there's thousands of files and likely over a Gigabyte. Proceed with installing the upgrade.

  6. Wait until it completes, approve if asked. I don't recall the exact details

  7. After the reboot the new version is running successfully, and all updates can be fetched normally.

  • 1
    It took me a while to find this post. Only using the referenced tarball I succeeded in getting the upgrade running from 15.04 / wily. The approaches using the old-releases urls did not work. I hope this helps other users getting into this problem.
    – Jeroen
    Commented Dec 19, 2016 at 9:34
  • I'm glad you found it helpful! Commented Dec 21, 2016 at 19:35
  • 1
    Seriously thanks for this, I just used these steps to upgrade 10.04 to 12.04. My issue was different in that my install wasn't corrupted, but there was an error on do-release-upgrade which I was unable to find in the terminal. Following these steps popped up a dialog telling me "error authenticating some packages" which led me to askubuntu.com/a/426121/262601 which DID allow the upgrade to continue successfully. Was pulling my hair out, but its my own fault for not upgrading sooner.
    – Fooxz
    Commented Jan 6, 2017 at 0:27
  • Unfortunately, not even this works for 15.04 Commented Jan 22, 2018 at 18:32
  • 1
    This still works well! I had to fix the 17.10 URL from the meta-release file, which isn't updated to old-releases, but that's usually unnecessary. I recommend that users who encounter problems ensure the upgrade was at some point supported--one of these situations or that situation--and also consider combining this with the preparation other answers suggest, like enabling the old-releases server and upgrading all packages within the current release before starting. Commented Aug 19, 2019 at 17:34

To get apt-get working again, change your software sources to the old release repositories.

sudo nano /etc/apt/sources.list

delete whatever is in there, and paste the following:

# Required
deb http://old-releases.ubuntu.com/ubuntu/ karmic main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ karmic-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ karmic-security main restricted universe multiverse

# Optional
#deb http://old-releases.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

That's all.

  • Thanks mikewhatever, but the result is the same when I try "apt-get install lm-sensors". Maybe there's another missing source: "Reading package lists... Done Building dependency tree Reading state information... Done Package lm-sensors is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package lm-sensors has no installation candidate"
    – Rorro
    Commented Apr 13, 2012 at 10:55
  • Here are the debs: old-releases.ubuntu.com/ubuntu/pool/main/l/lm-sensors-3. I trust it, you've reloaded the sources list, right? Commented Apr 13, 2012 at 12:08
  • This answer does not work... Why does it have so many upvotes? Did anybody actually test it? Commented Aug 15, 2014 at 11:00
  • I've tested it, but the real question is: Why are you still on Karmic? It's been out of support for years, and you should really move on to a more recent release. Commented Aug 15, 2014 at 12:13
  • This helped me after many other dead ends. One thing not mentioned is that you'll need to correct any urls inside the sources list files. the version number in the url has to match the ubuntu version name. Commented Jul 26, 2022 at 2:17

While fossfreedom's answer does a good job of describing and solving the problem, I've found a variant solution that I think is easier and a little more elegant.

The trick is to add http://old-releases.ubuntu.com/ubuntu/ as a mirror, and then tell Software Sources to switch to that mirror.

To do this, backup and edit /usr/share/python-apt/templates/Ubuntu.mirrors. Choose a fake location for the old-releases server (e.g. #LOC:US), and add the following line under it:


Now open the system's Software Sources dialog, and manually select old-releases.ubuntu.com as though it were your regional mirror. You should find it listed under the fake location you chose in the previous step.

The next time you reload your package information via Synaptic or Update Manager, you should see it successfully retrieving updated package information.

  • Works fine, very easy & quick
    – doug
    Commented Jul 22, 2014 at 1:42

Upgrade a very old Ubuntu

If your Ubuntu (Kubuntu, Xubuntu, Mythbuntu, whatever-buntu) is really old, you will have to take three steps to upgrade to an up-to-date version:

  1. Hack the package updater (APT) to upgrade your system to the latest available in the old-releases repository (including the release upgrade manager).
  2. Hack the release upgrade manager to make it agree to upgrade to the next (officially unsupported) release.
  3. Do the actual release upgrade (and repeat).

Remember, you are only allowed to upgrade from one "normal" release to the next and from a Long Time Support (LTS) release to the next LTS release.

Update the system to the newest available in http://old-releases.ubuntu.com

Set the package sources to old-releases.ubuntu.com and update

sudo cp /etc/apt/sources.list /etc/apt/sources.list.save
sudo sed -i -re 's/([a-z]{2}\.)?archive.ubuntu.com|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list
sudo apt-get update && sudo apt-get dist-upgrade && sudo apt autoremove

Here you can try a release upgrade if your current release is not too old (sudo do-release-upgrade). If it fails, you may find some clues in /var/log/dist-upgrade/main.log which could help to find a fix.

If your release is too old, go to next step.

Configure the release upgrade manager with local data

Retrieve the meta-release files

wget -O - http://changelogs.ubuntu.com/meta-release  > meta-release
wget -O - http://changelogs.ubuntu.com/meta-release-lts  > meta-release-lts

Edit meta-release to set all the next releases as supported

You must set Supported: 1 for each release.

Example: I was on Ubuntu 17.04 (Zesty Zapus) and set all the releases supported starting from artful.

Dist: artful
Name: Artful Aardvark
Version: 17.10
Date: Thu, 19 October 2017 17:10:00 UTC
Supported: 1
Description: This is the 17.10 release
Release-File: http://old-releases.ubuntu.com/ubuntu/dists/artful-updates/Release
ReleaseNotes: http://changelogs.ubuntu.com/EOLReleaseAnnouncement
UpgradeTool: http://old-releases.ubuntu.com/ubuntu/dists/artful-updates/main/dist-upgrader-all/current/artful.tar.gz
UpgradeToolSignature: http://old-releases.ubuntu.com/ubuntu/dists/artful-updates/main/dist-upgrader-all/current/artful.tar.gz.gpg

Also, check that the URLs for UpgradeTool and UpgradeToolSignature start with http://old-releases.ubuntu.com (not http://archive.ubuntu.com).

Edit /etc/update-manager/meta-release to point on local meta-release

Replace the original URIs with URIs pointing on your local meta-release files

URI = file:///home/chris/meta-release
URI_LTS = file:///home/chris/meta-release-lts


sudo do-release-upgrade
sudo apt-get update && sudo apt-get dist-upgrade && sudo apt autoremove

Reboot when asked to.

Redo it until your system is up to date.

When asked, answer that you want to keep your edited version of /etc/update-manager/meta-release excepted on the last upgrade.

When you are stuck to an old release

The process described above worked for me to upgrade to an unsupported release, and then to the last LTS release and I couldn't upgrade anymore.

What I did: Ubuntu 17.04 (Zesty Zapus) → Ubuntu 17.10 (Artful Aardvark) → Ubuntu 18.04 (Bionic Beaver)

Then I found the -p (--proposed) option of do-release-upgrade.

do-release-upgrade -p

It tries to upgrade to the newest available release! And it worked: I skipped two releases and jumped directly from Ubuntu 18.04 (Bionic Beaver) to Ubuntu 19.10 (Eoan Ermine)!

Maybe it would have worked to upgrade Ubuntu 17.04 (Zesty Zapus) to Ubuntu 19.10 (Eoan Ermine) in one run.

  • 1
    This is the cleanest approach.
    – skitheo
    Commented Aug 18, 2023 at 16:58
  • It's a pity that I can't mark the answer with do-release-upgrade -p the best, the simplest, forever topmost and the only one working :-) Commented Sep 29, 2023 at 18:23

It appears the Karmic repositories are no longer available.

Since they are for a previous version of Ubuntu, you might consider removing them from your sources list. Take a look at this help page for step-by-step.


You can find the repositories under the "old-releases" server http://old-releases.ubuntu.com/ubuntu/dists/

And about how to edit the /etc/apt/sources.list https://help.ubuntu.com/community/EOLUpgrades

  • Thanks gajdipajti, I'm looking for it inside the package list, but cannot find the correct ".deb". My ubuntu already has "libsensors3", but all the packages ask me for the "libsensors4". I know the normal solution should be upgrade, but I cannot do it because the computer is dedicated to be used with a software that only runs on 9.10.
    – Rorro
    Commented Apr 13, 2012 at 10:34
  • @Rorro: Which software only runs on Ubuntu 9.10? Commented Oct 9, 2013 at 1:45

There is an edge case - apt-get claims 16.04 LTS does not exist - where the old package (Vivid, in my case) was not in on the "old-releases" server. But apt-get could only find kernel and Google updates.

I am not sure exactly what my problem was because I had blindly followed the accepted answers sed command (never a smart move).

This did not work because Vivid was not in the "old-releases" archive but was still on the gb.archive.ubuntu.com mirror.

In that specific case, the solution was as follows:

sudo -i
edit /etc/apt/sources.list

Carefully go through all the sources and discover one of them was old and wrong and had failed to be properly updated (or something). Or, as I did, search replace from old-releases.ubuntu.com to gb.archive.ubuntu.com. It then upgraded, without a problem, to the next release while I caught up on some reading.

So either:

  1. There was a fault in my sources
  2. The gb.archive.unbuntu.com mirror has an older set of releases.

The takeaway here is that while the majority of answers here may apply in some cases it would pay to be sure that your /etc/apt/sources.list is correct before you nuke it for the "old-releases" archive.

You can figure out which of the archive or your mirror has the version you need by simply pointing a browser tab at the archive and question and looking for your version name in the folder list. Whichever one has your version, is the source you need to use.


18.10 to 19.10 Ubuntu upgrade

If you have EOL release and if you do not afraid of reinstalling your system from scratch or just without formatting this older system, than you could try it. It tried only of curiocity and for testing purposes. Not real hardware, but VM have been used for this. DO NOT USE IT ON PROD. But strangely if you have EOL on prod.

Trying to correctly answer the question I've installed Ubuntu 18.10 eol into VirtualBox VM.

  • I changed current /etc/apt/sources.list to 18.04 Ubuntu's version:

    deb http://ua.archive.ubuntu.com/ubuntu/ bionic main restricted
    deb http://ua.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
    deb http://ua.archive.ubuntu.com/ubuntu/ bionic universe
    deb http://ua.archive.ubuntu.com/ubuntu/ bionic-updates universe
    deb http://ua.archive.ubuntu.com/ubuntu/ bionic multiverse
    deb http://ua.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
    deb http://ua.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
    deb http://archive.canonical.com/ubuntu bionic partner
    deb http://security.ubuntu.com/ubuntu bionic-security main restricted
    deb http://security.ubuntu.com/ubuntu bionic-security universe
    deb http://security.ubuntu.com/ubuntu bionic-security multiverse
  • Changed /etc/lsb-release to:

    DISTRIB_DESCRIPTION="Ubuntu 18.04 lts"
  • sudo apt update && sudo apt upgrade && sudo do-release-upgrade

During upgrade it failed to restart different services and even rejected to reboot or shutdown correctly. I've powered the VM off and started it again.

It started without issues.

$ cat /etc/lsb-release && uname -a
Linux ubuntu18 5.3.0-40-generic #32-Ubuntu SMP Fri Jan 31 20:24:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Applications are opened correctly.
/etc/apt/sources.list have been generated with duplicates of eoan repositories, so I've removed excessive records and now it is:

deb http://us.archive.ubuntu.com/ubuntu/ eoan main restricted
deb http://us.archive.ubuntu.com/ubuntu/ eoan-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ eoan universe
deb http://us.archive.ubuntu.com/ubuntu/ eoan-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ eoan multiverse
deb http://us.archive.ubuntu.com/ubuntu/ eoan-updates multiverse
deb http://security.ubuntu.com/ubuntu eoan-security main restricted
deb http://security.ubuntu.com/ubuntu eoan-security universe
deb http://security.ubuntu.com/ubuntu eoan-security multiverse

Installed scribus, snap, mariadb-server, docker, openssh-server using sudo apt install without issues.

Installed gimp using snap: snap install gimp --classic (Authentication prompt appeared and after password input installation started)

It looks like a usual stable 19.10 Ubuntu system upgraded correctly as my host is.


In my case I was stuck in 19.04 for months because I didn't upgrades at time and I wasn't able to do the upgrade to 19.10 after that time. But the other day, Ubuntu automatically gives me the option to do a Partial Upgrade to 19.10 (maybe because I did a lot of stuff weeks ago, but sorry, I can't be sure the reason). So I did it and the result of lsb_release -a was Ubuntu 19.10. So I think I could be able to do another upgrade to 20.04.1, but isn't possible because 19.10 reached EOL.

The solution what I found today, 16 December 2020, to make an upgrade in Ubuntu 19.10 in EOL is to:

  1. Edit /etc/apt/sources.list

  2. Copy the following sources list (https://gist.github.com/ishad0w/788555191c7037e249a439542c53e170) :

    deb http://archive.ubuntu.com/ubuntu/ focal main restricted universe multiverse 
    deb-src http://archive.ubuntu.com/ubuntu/ focal main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu/ focal-updates main restricted universe multiverse 
    deb-src http://archive.ubuntu.com/ubuntu/ focal-updates main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse 
    deb-src http://archive.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
    deb http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse 
    deb-src http://archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
    deb http://archive.canonical.com/ubuntu focal partner 
    deb-src http://archive.canonical.com/ubuntu focal partner
  3. Paste it to your sources.list and disable with # the Eoan links.

  4. In a terminal: update-manager. This will open the Software Updater window and check for updates and upgrades. Here is where I be able to make another Partial Upgrade, in this case, to 20.04.1LTS. Another lsb_release -a shows that I am in 20.04.1LTS.

enter image description here

I hope this will serve for someone, someday.

Merry Christmas to all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .