the last update of thunderbird (the version is now 52.1.1 (64-bit)) on ubuntu 16.04 causes my mail client to get stuck with the message

Status: Creating mail message...

then nothing happens anymore. i can cancel but not send the mail again... this happens often. i then have to start a new message and try again until the message is sent.

is there a fix for that? is that a bug? i have not changed anything in the configuration of the mail accounts since the update.

update: as Debora Weber-Wulff pointed out this may be an enigmail related issue only. (confirmed!)

update: there is a bug report for enigmail.

  • Same thing here, but on a Mac OSX 10.11.6. Just one account (that uses Enigmail) has the same behavior. I can send encrypted emails from other accounts with no problem, but for this account (posteo.de) it just hangs. May 23, 2017 at 20:16
  • @DeboraWeber-Wulff: it may very well be that this is enigmail related. i don't think i have ever seen it happen with contacts i do not use gpg for... thanks! May 24, 2017 at 6:54
  • I have this problem as well on MacOS. I found that there are gpg processes running in the background. If I kill those processes, tb immediately crashes. This is definitely an interaction between tb/enigmail/gpg. May 24, 2017 at 15:08
  • And I can send unencrypted emails from the posteo account without problem. I can also accept encrypted emails at the posteo account and decrypt them without problem. So it seems to be a general Thunderbird/Enigmail/GPG interaction, not so much an Ubuntu problem. Now, where do we find help? ;) May 24, 2017 at 16:06
  • Just found a bizarre workaround: save the email in the drafts folder by selecting that from the menu. Then it will send just fine.... May 24, 2017 at 16:19

3 Answers 3


Yes, it appears to be this bug: #687 Enigmail hanging on send - Thunderbird 52.1.1


One suggested work-around (confirmed by multiple bug report commentators) is to kill all GPG processes,

killall gpg gpg2

and try again.

Beta-version with fix

You can also install the pre-release version 1.9.8-a3 of Enigmail that's supposed to contain a fix.

  • the prerelease 1.9.8-a3 has worked several days without a glitch so far! thanks. Jun 7, 2017 at 12:39
  • argh! and right now the bug reappeared with the pre-release version... Jun 7, 2017 at 12:44

the developer of enigmail has released a new pre-release (1.9.8-a4) of enigmail; as announced in a post on the bug tracker.

the bug has never shown up in this version.


I have had this problem but my work-around is just to click on the 'X' to close the compose window, then choose the option to save the draft. Then open, edit and send the draft and it has always then gone without any further problems.

I also changed the location of my drafts folder to a local folder because prior to that I ended up with lots of encrypted 'drafts' that had to be manually deleted as each draft, when encrypted, was unique. With a local drafts folder the drafts are unencrypted and are deleted automatically when sent.

  • I changed the location to local as well and updated to (soon to be, works now. Aug 1, 2017 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.