0

running Virtualbox 5.1 on my HP elitebook 840, the OS is Ubuntu 16.04 LTS, 64-bit.

I get the error: "VT-x/AMD-V hardware acceleration is not available on your system. Your 64-bit guest will fail to detect a 64-bit CPU and will not be able to boot."

I checked posts related to that issue but most people problem is enabling VT-X. But here are the results of my checks:

lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 69
Model name:            Intel(R) Core(TM) i5-4200U CPU @ 1.60GHz
Stepping:              1
CPU MHz:               1599.920
CPU max MHz:           2600.0000
CPU min MHz:           800.0000
BogoMIPS:              4589.31
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              3072K
NUMA node0 CPU(s):     0-3
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm epb tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid xsaveopt dtherm ida arat pln pts

I also tried:

grep --color vmx /proc/cpuinfo

and vmx did turn red (as it should according to this post).

So i guess my problem is somewhere else. Any idea what´s going wrong?

Thanks

  • Try this two commands and tell me what numbers you get sudo modprobe msr, and /or sudo rdmsr 0x3a – George Udosen May 23 '17 at 5:33
  • 1
    The output of lscpu will only tell you that your CPU is capable of VT-x but not whether it was enabled in BIOS. There, the option to enable it will have many different names, depending on brand. Sadly some manufacturers had disabled it entirely and forgot to add a BIOS option to enable it, but this should really be an exception and may not be the case with your hardware. – Takkat May 23 '17 at 6:24
0

Sorry, i solved it in between and forgot to report here. VT-x wasn't enabled, i just followed as tuto to enable it for my model of laptop and everything runs perfectly since. Thanks for the help anyway!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.