0

I downloaded Ubuntu 16.04 and used Rufus to format an 8GB PNY flash drive and make it a bootable drive. I took great care in following the instructions given on the Ubuntu website.

The problem is, when I restart, no matter what I set the boot order to in the BIOS (USB HDD first, USB FDD first, hard disk, etc.) I always end up booting to Windows normally. A user on another thread recommended checking inside the hard disk option, as sometimes the USB is hidden in there, but my only options there are my hard drive and "add-in cards".

I have tried re-downloading Ubuntu, re-formatting the USB drive, and scoured my BIOS for settings that could apply.

I have spent hours trying to troubleshoot this and I have hit a wall.

PC Specs:
• Manufacturer: iBUYPOWER
• Processor: AMD FX-8320 3.5 GHz
• RAM: 16 GB • OS: Windows 10 64-bit, 10.0.14393 Build 14393
• BIOS mode is Legacy.
• Secure Boot State is unsupported.
• BIOS version is Award Software International Inc. F2, 11/25/2014.

(If any other details are needed, just ask)

  • You find more tips at the following link, help.ubuntu.com/community/Installation/FromUSBStick, and links from it. Also, it is worth testing the USB boot drive in some other computer. I think Rufus is a reliable tool, but it is worth testing that the USB drive really works (in another computer) to eliminate that cause of your problem. – sudodus May 23 '17 at 3:58
  • Just got home and tested the USB in my laptop, and Ubuntu booted flawlessly (did not even have to select the drive from boot menu, it did it itself). – Cody May 23 '17 at 20:03
2

can you press f11 during the first boot screen to get a boot menu that lists all of the detected boot devices? after power button press you want to immediately start tapping f11 a few times once every second, just to make sure it catches it.

it should still be visible as a boot device regardless of whether or not it is setup to boot. so I would establish having the bios see the usb drive before you try reformatting/setting up as a usb install disk again. maybe make sure to use a usb port in the back of the computer and possibly a usb 2.0 port(non-blue) to remove an other possible issues, also possibly check your bios usb settings, to ensure it is enabled

maybe try temporarily disconnecting your main drive, to speed up troubleshooting, to prevent having to boot into windows.

  • Upon restarting and opening the boot menu, the options listed are as follows: LS120, +Hard Disk (inside lists 'ch2. m. Toshiba' and 'Bootable Add-In Cards'), CDROM, ZIP, USB-FDD, USB-ZIP, USB-CDROM, USB-HDD, LEGACY LAN. All USB ports should be enabled, as they all work to read USB drives and operate my peripherals. – Cody May 23 '17 at 20:34
  • @Cody, All USB ports might not be activated at the very early stage of booting, when the computer is supposed to find the operating system from the USB pendrive. So it is a good idea to try different USB ports. It is also a good idea to try all different options in the boot menu and to change the default boot order between the different hard disk drives. (A USB pendrive is a mass storage device, and might be regarded as a hard disk drive.) Sometimes the names of the options are somewhat confusing, so it is worth trying options, that 'look wrong'. – sudodus May 24 '17 at 3:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.