0

I'm not able to connect to the internet from the past 2 days, I looked at many similar posts but none of them works for me. I am very new to ubuntu and this is very annoying please help

Things I have tried:
Tried to restart my network manager which failed

sudo restart network-manager

restart: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

then I looked at ifconfig -a eth0 is not being recognized at all, the output is

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1615 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1615 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:147010 (147.0 KB)  TX bytes:147010 (147.0 KB)

wlp6s0    Link encap:Ethernet  HWaddr 4c:bb:58:2b:14:35  
          inet addr:192.168.43.254  Bcast:192.168.43.255  Mask:255.255.255.0
          inet6 addr: fe80::4838:90b3:dca2:86ce/64 Scope:Link
          inet6 addr: 2405:204:531e:115a:7e2e:5204:7145:83ae/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9235 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9918 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6611860 (6.6 MB)  TX bytes:1935577 (1.9 MB)

I also tried to change the /etc/network/interfaces file from this :

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

to this:

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

nothing seems to work. please help..

Output from lspci:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
06:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
6
  • I suggest you reinstall: sudo apt-get install network-manager
    – saviour123
    May 22 '17 at 12:23
  • @saviour123 nope, it did not work either, im getting the same error message..
    – Zayd Khan
    May 22 '17 at 12:33
  • The last line of ifconfig -a shows an Ethernet controller. So there is hardware present. Did you accidentally disable Networking? Click on the double arrow/wifi icon to check a tick next to Networking.
    – user680858
    May 22 '17 at 15:04
  • @WillemK no, networking is enabled.. :(
    – Zayd Khan
    May 22 '17 at 17:44
  • Do you see any leds at the connector? If you boot Live USB does it work then?
    – user680858
    May 23 '17 at 4:08
2

If your Ethernet card is inserted into your motherboard, typing ifconfig -a would show eth0 even without plugging the cable in.

So, check if your Ethernet card is securely inserted into your motherboard and see if your motherboard recognize it. If not, unplug the Ethernet card and plug it in again.

5
  • That wlp6so appears only when i connect to any hotspot
    – Zayd Khan
    May 22 '17 at 12:32
  • Did you check if your ethernet card is securely connected to your motherboard? May 22 '17 at 12:34
  • I am using a laptop.. and yes it is connected properly.. i even removed and inserted it back.. my os is not recognising eth0
    – Zayd Khan
    May 22 '17 at 12:41
  • type lspci to see if it recognizes your ethernet adapter. Give us the output of that by editing your quesion. May 22 '17 at 12:44
  • yes i have edited the output...
    – Zayd Khan
    May 22 '17 at 12:51
1

Saw this post and downloaded the drivers.. and i did these steps and got my connection back.. still have no idea what went wrong..

First downloaded these files:

http://mirrors.kernel.org/ubuntu/pool/universe/r/r8168/r8168-dkms_8.040.00-1_all.deb http://mirrors.kernel.org/ubuntu/pool/main/d/dkms/dkms_2.2.0.3-2ubuntu6_all.deb

sudo dpkg -i r8168-dkms_8.040.00-1_all.deb dkms_2.2.0.3-2ubuntu6_all.deb

sudo modprobe -r r8169

sudo modprobe r8169

and voila i got my connection back.. Thanks for all the help...

7
  • I'm interested... does the interface still show as eth0?
    – user680858
    May 24 '17 at 3:41
  • no.. it has a different name.. wpl6s0, and another problem which i am facing now is that every time i switch on my laptop i have to run that last command in order to start my wired connection, else my laptop won't recognise that there is an Ethernet port connected.. @WillemK
    – Zayd Khan
    May 24 '17 at 13:48
  • I cannot find the post, but I vaguely remember a case where the network card also wasn't recognized at startup and if I remember correctly it had to do with powersave. Sorry I cannot be more specific. But if you only have to enter that last command, you can put it in your login profile.
    – user680858
    May 24 '17 at 14:29
  • Im very new to ubuntu, i just hope this does not cause any further problems to me, i will add that command in the startup... @WillemK
    – Zayd Khan
    May 25 '17 at 12:29
  • Well, it is a strange situation. It is not very often that a wired interface starts having problems. You hear more about wifi problems. Ubuntu 16.04 is a very stable version... usually. Do you remember anything that happened to it that be have caused the problems. You could consider a fresh install or even a second install if your disk has any free space.
    – user680858
    May 25 '17 at 15:06
1

There is a bug in managed connections, it may be the cause. Move this file to another location or delete it:

/usr/lib/NetworkManager/conf.d/10-globally-managed-devices

Here is the bug description:

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1638842

1
  • 1
    I don't have any folder or file named conf.d.. :(
    – Zayd Khan
    May 22 '17 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.