16

I am no longer able to write on the data partition files in Ubuntu, due to a "read-only" message appearing.

I have 3 partitions: one has Ubuntu installed (1), one is for Win10 (2) (dual boot) and the 3rd (3) is for data storage.
Today I updated Win10 and I am no longer able to access the data storage (3) partition from Ubuntu. Usually this error appears when I access Ubuntu while Win10 is not shut down but hibernated. Instead this time the error appears even if Win10 is shut down!
I don't get what's going on. Any clue?

25

The Windows 10 update reseted it to the default fast startup which is a form of hibernation.

You need to disable this feature (again, probably) in Windows and then shutdown, not reboot. Once done properly you'll be able to access the data partition normally with read/write permissions.

The location of Fast Boot option in windows10

| improve this answer | |
  • I have changed that option from windows and now it works, thanks. – danieleg91 May 22 '17 at 10:20
  • 1
    This happened to me in the last month. It's really very sucky that Windows changes the setting back. It cost me quite a bit of time. – TooTone Apr 12 '18 at 9:09
  • I've had that setting off and it was still returning a Read Only message. The solution is the same as above, boot into Windows and perform a normal shutdown. – Francis Aug 11 '18 at 4:38
  • This option is disabled in my case, as I am using office laptop. – Prashant Adlinge Mar 10 at 18:12
  • This has been bugging me for months now without any fix in site. This fixed it. Appreciate it. – munchschair May 12 at 11:55
4

Open the terminal and write the command

sudo fdisk -l

It will show your file system

identify the partition you want permission for read and write

then type the command and give the partition name like this to your specific sda

sudo ntfsfix /dev/sda3
| improve this answer | |
1

Sometimes the feature "Disable Fastboot" is prohibited to change by non-admin user by group policy restriction.

The below solution will help for all situations.

Login to windows, close all opened windows if any and execute following, from Run dialog

shutdown /f /r /t0

/f Force running applications to close without forewarning users.

/r Full shutdown and restart the computer.

/t xxx Set the time-out period before shutdown to xxx seconds, here /t0 for immediate shutdown.

| improve this answer | |
0

Windows is hibernated, refused to mount

Chances are that Windows really is hibernated. Windows does this automatically when you tell it to shutdown normally. The benefit is that you get a faster apparent start-up time.

To shutdown Windows without hybernating, issue the following at a command-prompt (in Windows):

shutdown /s

You might also want include /t 0 for immediate shutdown.

I found a nice tutorial to set up a launcher for this: How to Do a Full Shutdown in Windows 8 Without Disabling Hybrid Boot.

The simpler approach to actually shutting down Windows is to 'restart' (rather than 'shutdown'), but then intercept the boot process and boot Linux instead of letting it boot Windows.

credit: nobar

| improve this answer | |
0

for me it was solution to restart from Linux go to windows, restart from windows and go bask to Linux. I guess windows did not close some permissions.

| improve this answer | |
  • When you restart Windows from the login screen, the Windows won't suspend. That's why you were able to disable the fast boot by restarting the Windows. – Gui Apr 13 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.