3

This question already has an answer here:

I was just wondering how to disable bluetooth startup by default in 17.04. I would like to be able to boot, and not have to turn off bluetooth every time. Any help would be greatly appreciated.

Thanks

marked as duplicate by Jeremy31, Sumeet Deshmukh, Pilot6, Ravexina, Charles Green May 23 '17 at 13:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2

If I'm not mistaken you can turn it off in the systemsettings and it will stay offline?

If this doesn't work you can disable the service itself.

sudo systemctl disable bluetooth.service && sudo systemctl stop bluetooth.service

If you want to activate it again.

sudo systemctl enable bluetooth.service && sudo systemctl start bluetooth.service

The enable and disable is used so during the next startup it is either started or not.

  • 1
    Not really the answer.... I want to know how to get bluetooth to not come on at startup, but be readily AVAILABLE to use. I don't want to disable the bluetooth completely then have to re-enable it when I use bluetooth. I just don't want the unnecessary bluetooth service running while I'm not using it. I'll never remember, if I need bluetooth, that I need to run some cmd bs to get it working again. – Robert Sederholm May 27 '17 at 15:15
  • Huh? You don't want to disable it so use just the stop/start command. I did write the enable/disable is for if you don't want it to be run during start up. Read it completly before answering in such vulgar language. – Ziazis May 28 '17 at 16:54
  • Did I need to reboot for this to take effect? I'll accept the answer if so. I didn't reboot or log out, so maybe it was my bad. I'm on Ubuntu GNOME now, and I don't have the same problem so I can't check..... – Robert Sederholm Jul 23 '17 at 2:57
  • 1
    Okay well this answer never worked for me, sorry. Idk what it was about my system but in this specific case, that wasn't the answer for whatever reason. – Robert Sederholm Jul 23 '17 at 15:05
  • 1
    The OP would like the Blueman to stay in the systray, but the system as a whole to boot up essentially with the right-click option "Turn Bluetooth Off" already done. The systemctl options disable Blueman altogether, making it more difficult to use Bluetooth. – Adrian Keister Jan 30 '18 at 14:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.