2

I'm trying to install Xdebug on Ubuntu Zesty (17.04), but am having trouble resolving dependencies. I'm following instructions from this url:

https://xdebug.org/wizard.php

Point 4. there says "Run: phpize (See the FAQ if you don't have phpize." When I do, I get the following error:

The program 'phpize' is currently not installed. You can install it by typing: sudo apt install php7.0-dev

I don't know why php7.0-dev is offered, my PHP version is 7.1. So instead, I tried installing php7.1-dev. Then I got this message:

php7.1-dev : Depends: libssl-dev but it is not going to be installed

Finally, if I try installing libssl-dev manually, this is what I get:

libssl-dev : Depends: libssl1.0.0 (= 1.0.2g-1ubuntu11) but 1.0.2k-1+deb.sury.org~yakkety+1 is to be installed

How do I resolve this problem?

  • Try my post askubuntu.com/questions/889367/… – George Udosen May 21 '17 at 18:56
  • George when I run sudo apt install php-all-dev, I get: php-all-dev : Depends: php5.6-dev but it is not going to be installed Depends: php7.0-dev but it is not going to be installed Depends: php7.1-dev but it is not going to be installed – Томица Кораћ May 21 '17 at 19:03
  • Try sudo apt install -f then update your system and try again – George Udosen May 21 '17 at 19:05
  • Just did, same result. I believe the reason why I can't install php-all-dev is the same dependency issue from my question. Any idea how do I resolve it? – Томица Кораћ May 21 '17 at 19:08
  • 1
    Well you have packages from a ppa for yakkety (openssl) that are higher versioned than the same in zesty's default repos ( and that ppa doesn't offer openssl for zesty). So either get rid of the yakkety packages or see what aptitude offers to do – doug May 21 '17 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.