0

I am setting up an encrypted partition with a special script to automatically input the passphrase. The partition is not a system partition and the process requires a custom keyscript.

I've managed to configure almost everything and test the configuration without rebooting the machine, just by using cryptdisks_stop, crypdisks_start. The encryption have a master passphrase, that can by typed in (slot 0) and a binary key that is supposed to be used in the unattended boot.

I've also created a hook script to initrd to copy the custom keyscript to the initrd image, and I've checked that the file was inside it by unpacking the cpio image of initrd in a temp dir.

However, when booting, the system still asks for typing a passphrase.

What is missing?

2
  • 1
    I think you are running into the same problem as this question [askubuntu.com/questions/906870/…. Short answer is systemd has a bug when trying to use a keyscript (the keyscript function is not implemented). You could try to use a keyfile instead if the password is static – sergtech May 21 '17 at 10:28
  • I second that. It sounds a lot like the problem I asked about in the link from the previous comment. See if your logs report anything like what I posted in my update (on my question). As there may be more than one way to skin this cat, mind posting your keyscript file? Perhaps what you want to do can be accomplished another way. – b_laoshi May 22 '17 at 5:19
0

Try option "initramfs" in /etc/crypttab as described here: https://askubuntu.com/a/1149273/437357

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.