1

I've had a problem with the persistence module in Ubuntu 17.04. (I have used this particular file for any diagnostic help: ubuntu-17.04-desktop-amd64.iso.)

I have followed several steps including:

  1. Creating a bootable USB using Linux Live USB Creator in Windows, creating a 4GB persistence module on a FAT32 usb (Sandisk, 32GB) - Failed, none of my settings/apps remained

  2. Created a USB while in Ubuntu 17.04 in Unetbootin, FAT32, 4GB persistence module - Failed, none of my settings/apps remained

  3. Formatted the same USB stick with Gparted, creating a 4GB FAT32 partition, a 4GB ext4 partition (labeled "casper-rw"), and a spare remaining FAT32 partition. Used Unetbootin to install Ubuntu 17.04 + 10MB persistent module, then removed the 10MB persistent module. link here.

  4. I have tried another 16GB ADATA USB stick and formatted it using method 2) above, thinking maybe settings did not apply because of something to do with the brand of the USB stick. I'm kind of out of options

If it helps, I've selected "Try Ubuntu Without Installing" everytime the prompt comes up; however, I'm not sure if this information is pertinent to my problem or not.

  • @Alban - Honestly, I wouldn't mind performing an install onto the USB as to have the entire REST of the USB as persistent storage. – EskinubisPrime May 21 '17 at 22:19
  • Also, in attempting to install Ubuntu to the USB drive, I got the following: Error mounting /dev/sda1 at /media/ubuntu/Ubuntu 17.04 amd64: Command-line 'mount-t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=999,iocharset=utf8,mode=0400,dmode=0500" "/dev/sda1" "/media/ubuntu/Ubuntu 17.04 amd64"' exited with non-zero exit status 32: mount: /dev/sda1 is already mounted or /media/ubuntu/Ubuntu 17.04 amd64 busy. This was followed by an error during the USB installation prior to booting. I selected "Install Ubuntu" at the Grub2 menu and it error'd out. – EskinubisPrime May 22 '17 at 4:39
2

Sounds like you have tried just about everything but mkusb,

I would recommend trying mkusb first: https://help.ubuntu.com/community/mkusb

It can create a bootable 'buntu flash drive, with Boot on FAT32 partition, OS on read only ISO9660 partition, persistence on ext casper-rw partition and NTFS partition accessible to Linux and Windows. It works with BIOS or UEFI.

(Persistent partitions are not currently working with syslinux installs such as LiLi and Unetbootin).

  • I setup the 32GB SanDisk with the same x64 ISO using the mk-usb. I set it up with the remaining USB space (100%) to be the persistent partition. It originally booted up perfectly fine. In order to test it, I setup the multiverse installable setup, etc for downloads and whatnot, ran the sudo apt update and sudo apt install cairo-dock -y for a test run to check persistence. However, on reboot, the system stayed on the Ubuntu passing screen. All hardware notification lights (including the USB read/write light) changed to their idle states. – EskinubisPrime May 22 '17 at 2:42
  • I've tried running with persistence regularly (1st option). Following that, I attempted running with persistence and OS in RAM (2nd option). I'm not sure what happened. Any suggestions for setup? – EskinubisPrime May 22 '17 at 2:43
  • [Correction]: "However, on reboot, the system stayed on the Ubuntu [*loading] screen." – EskinubisPrime May 22 '17 at 4:45
  • As a rule I never do a general update on a Persistent flash drive and never ever do a general upgrade, updates quickly fill the drive, and the kernel is part of a read only file and can't be upgraded. Better to do a Full install to flash drive if you want updates, upgrades, good security or a faster boot.. – C.S.Cameron May 22 '17 at 15:17
1

The problem was the persistence settings. While creating the persistence file in mkusb, I tried utilizing around 80 - 95% of the remaining space for persistence with absolute success! Thank you @C.S.Cameron! I saw this note in another mkusb guide here, "Note: Do not enter a value like 100% as some memory will be required for the Ubuntu OS files."

  • 100% for persistence means 100% of the space available, when the system partitions are already created. There was a bug in earlier versions of mkusb, that made it impossible to use 100%, but it works in mkusb 11.1.7 and newer versions: "fixed bug for 100% persistence: using 'ntfssize' in mkusb". The current version is 12.1.5. – sudodus May 25 '17 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.