5

I'm quite used to typing with Compose key on my right Alt. I've recently installed the new Ubuntu GNOME 17.04, and it seems like they only dumb down the settings and features with every new version of GNOME.

How can I set up the Compose key in this version? The keyboard settings don't look anywhere near what they did in the older versions for some reason; I just can't find it anywhere.

  • 2
    The setting is in gnome tweak tool > typing – chaskes May 20 '17 at 19:24
  • 1
    You're welcome. If I (or someone who beats me to it) makes a true answer, please remember to come back and accept it. :) – chaskes May 20 '17 at 20:17
  • 2
    There doesn't seem to be a Compose key option in Gnome Tweak Tool for me (version 3.18.1), so I had to change it in dconf as explained by another answer. – Harry Cutts Dec 26 '17 at 21:50
4

As chaskes pointed out above, you can set the key in Tweak Tool > Typing. There is a fold-out menu named 'Position of Compose Key' which you can set to the key you want.

To activate the changes you may need to log out and log back in.

1

They've completely left out even the possibility of using the INSERT key. It has never been useful, and the name "insert" actually makes sense for inserting Unicode.

0

Command line command to set the compose character to Caps Lock (finally this key becomes useful ♥):

gsettings set org.gnome.desktop.input-sources xkb-options ['compose:caps']

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.