I just installed Ubuntu for the first time and I have no experience with Linux. One of the first things I noticed is that it appears the palm rejection for my laptop is gone. I have been googling this for an hour and tried a variety of different step-by-step guides, but for whatever reason I cannot seem to figure this out. I'm hoping someone can help me with my specific case. I would love to take the time to learn Linux, but I feel like I just need to get this out of the way first so I can type again without my hands at an incredibly unergonomic angle. I'm running 16.04 on a Dell Inspiron laptop. Thanks in advance.

  • @Alban is correct, it's a Windows vs. Linux drivers issue, but if you like, you should be able to disable "Tap to click" in the touchpad settings. This might be inconvenient unless you have a clickpad, like on many of the newer Inspiron laptops. – Nonny Moose May 20 '17 at 18:36

It's an old question, but seems to be unanswered so I'll throw in my two cents:

I'm running an Asus Q501D with 16.04, and I found that following this guide solved the issue.

The essence of it is modifying your xinput touchpad, which you find by running xinput list in the terminal and locating your touchpad device, whatever it be named, and its id in the output.

Then you modify the parameters using xinput set-prop [id] [prop] [setting] to enable palm rejection and change the dimensions of the palm region. You can see all of your touchpad's props in the output xinput list-props [touchpad device id].

The relevant props were "Synaptics Palm Detection" and "Synaptics Palm Dimensions". You'll want "Synaptics Palm Detection" 1 and "Synaptics Palm Dimensions" #, # to be something that actually rejects your palm (5, 5 worked for me and the author of the article).

Then it's just a matter of adding those prop-setting commands to your Startup Applications so that they run when you reboot (and thus preserve your settings).

Again, the linked guide has a few more details and screenshots, so definitely look there if I've botched up the explanation. As a sidenote: The guide is written for 14.04, though, so maybe isn't compatible with all laptop makes depending on drivers? Users in the comment section of the guide seem to have mixed results, but could just be user error, worked just fine for my machine. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.