7

I have recently upgraded my Ubuntu server to the 16.04 release. Since then I can't start the nginx service.

Results of service nginx restart :

Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details.

What my system logs says (cat /var/log/syslog) :

May 20 17:03:53: Stopped A high performance web server and a reverse proxy server.
May 20 17:03:53: Starting A high performance web server and a reverse proxy server...
May 20 17:03:53: nginx.service: Failed at step EXEC spawning /usr/sbin/nginx: No such file or directory
May 20 17:03:53: nginx.service: Control process exited, code=exited status=203
May 20 17:03:53: Failed to start A high performance web server and a reverse proxy server.
May 20 17:03:53: nginx.service: Unit entered failed state.
May 20 17:03:53: nginx.service: Failed with result 'exit-code'.

Results of cat /lib/systemd/system/nginx.service :

# Stop dance for nginx
# =======================
#
# ExecStop sends SIGSTOP (graceful stop) to the nginx process.
# If, after 5s (--retry QUIT/5) nginx is still running, systemd takes control
# and sends SIGTERM (fast shutdown) to the main process.
# After another 5s (TimeoutStopSec=5), and if nginx is alive, systemd sends
# SIGKILL to all the remaining processes in the process group (KillMode=mixed).
#
# nginx signals reference doc:
# http://nginx.org/en/docs/control.html
#
[Unit]
Description=A high performance web server and a reverse proxy server
After=network.target

[Service]
Type=forking
PIDFile=/run/nginx.pid
ExecStartPre=/usr/sbin/nginx -t -q -g 'daemon on; master_process on;'
ExecStart=/usr/sbin/nginx -g 'daemon on; master_process on;'
ExecReload=/usr/sbin/nginx -g 'daemon on; master_process on;' -s reload
# Use TERM instead of QUIT to prevent Nginx from leaving stale Unix socket and failing the next start (https://trac.nginx.org/nginx/ticket/753)
ExecStop=-/sbin/start-stop-daemon --quiet --stop --retry TERM/5 --pidfile /run/nginx.pid
# Give Passenger a chance to clean up before being killed by systemd.
ExecStop=/bin/sleep 1
TimeoutStopSec=5
KillMode=mixed

[Install]
WantedBy=multi-user.target

There is indeed no file at /usr/sbin/nginx, so I tried apt install nginx, but here's the result :

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nginx : Depends: nginx-core (>= 1.10.0-0ubuntu0.16.04.4) but it is not going to be installed or
                  nginx-full (>= 1.10.0-0ubuntu0.16.04.4) but it is not going to be installed or
                  nginx-light (>= 1.10.0-0ubuntu0.16.04.4) but it is not going to be installed or
                  nginx-extras (>= 1.10.0-0ubuntu0.16.04.4) but it is not going to be installed
         Depends: nginx-core (< 1.10.0-0ubuntu0.16.04.4.1~) but it is not going to be installed or
                  nginx-full (< 1.10.0-0ubuntu0.16.04.4.1~) but it is not going to be installed or
                  nginx-light (< 1.10.0-0ubuntu0.16.04.4.1~) but it is not going to be installed or
                  nginx-extras (< 1.10.0-0ubuntu0.16.04.4.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

As a newbie, I'm pretty lost in that mess and I realy need a bit of help.

Thank you very much for your time.

Update 1:

Results of apt-cache policy nginx :

nginx:
  Installed: 1.12.0-1+xenial1
  Candidate: 1.12.0-1+xenial1
  Version table:
 *** 1.12.0-1+xenial1 500
        500 http://ppa.launchpad.net/nginx/stable/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/nginx/stable/ubuntu xenial/main i386 Packages
        100 /home/var/lib/dpkg/status
     1.10.0-0ubuntu0.16.04.4 500
        500 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages
     1.9.15-0ubuntu1 500
        500 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://ubuntu.mirrors.ovh.net/ftp.ubuntu.com/ubuntu xenial/main i386 Packages
1
  • I had something similar happen for a different reason. I'm not sure how this happened, but overnight, possibly because of a restart that triggered an update, Apache was running and was blocking Nginx from running. If the above doesn't work, you may want to see if you have apache running too. In which case, stop the apache service, then try to start nginx. Commented Feb 7, 2019 at 17:50

1 Answer 1

7

So you've got two things which are in conflict and have led it seems to the nginx binaries going away somehow: Xenial repository version, and the NGINX PPA. As the maintainer of both, allow me to explain the conflict.

In Xenial, we released 1.10.0 just after release as an update. This update pushed us to a 'stable' branch but didn't have dynamically-loadable modules built and made available. This was due to time but also build conflicts that arose during tests. We eventually got dynamic module support working, in Zesty.

In the PPA, we've always cloned directly from Debian. That means, we always had Debian's 'dynamic module' support, which conflicted with the Xenial packages and resulted in some installation and upgrade conflicts.


There's a small conflict here - you can't mix-and-match nginx-core (which is the default flavor installed for the nginx package in Ubuntu) and the PPAs, as it sometimes makes things disappearify. The problem here, then, is we need to remove the existing Ubuntu package and then install from the PPA only.

To resolve this, you'll first need to back up your nginx configurations you want to keep for your sites. That is, make a copy of your /etc/nginx/sites-available/ directory somewhere else (even in your user's home directory is fine, we just need a copy of the site configurations). As well, we'll need a backup of your website data, so copy that somewhere else as well (NOT in the standard docroot, so it doesn't get messed up).

Once you make the copy, you'll have to remove the existing nginx packages. This can be done with the following command:

sudo apt-get remove nginx nginx-common nginx-doc nginx-core nginx-full nginx-extras nginx-light

Once that is complete, run sudo apt-get update again just to make sure we have the most up to date version numberings.

Then, install nginx from the PPA - sudo apt-get install nginx nginx-full nginx-common should do this.

You should no longer be getting failed to start errors. Make sure your site configurations are still in place, and didn't get overwritten. If they did, restore from the backups we took earlier of the site config and the site data. Otherwise, you're all set.

6
  • Worked! Thank you very much for your help Thomas. Commented May 20, 2017 at 16:25
  • The only think that I could find that solved my problem. So does this mean that their was a small window of time where nginx was updated on Ubuntu where this was an issue? The reason I ask is that I created several Vagrant boxes off Xenial at different time periods. Not every VM had this issue, only the older ones do if I remember correctly.
    – David
    Commented Aug 23, 2019 at 3:36
  • @David I'm a little confused on the context here, but if you use Xenial and the PPA still the PPA nowadays is much newer, as a result those'd supersede the Xenial versions regardless, so this conflict is no longer relevant.
    – Thomas Ward
    Commented Aug 23, 2019 at 15:31
  • @ThomasWard I was having an issue when using the Ubuntu Xenial base box on some Vagrant VM's where NGINX would install, but I could not get the service to start on boot. I followed these directions and thought it worked, but upon reboot, NGINX was still not starting. I may be on the wrong thread. Pretty sure my issue is systemd related.
    – David
    Commented Aug 23, 2019 at 21:16
  • @David sounds like it needs it's own question post then because that sounds like a different issue entirely
    – Thomas Ward
    Commented Aug 23, 2019 at 21:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .