2

My wifi is no longer working under kernel 4.10 / 4.11. Here is the output from dmesg | grep iwl under kernel 4.11

[    2.307045] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7260-17.ucode failed with error -2
[    2.307049] iwlwifi 0000:02:00.0: no suitable firmware found!

And here is the output from kernel 4.4 - with wifi functioning

[    1.786652] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7260-17.ucode failed with error -2
[    1.796735] iwlwifi 0000:02:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
[    1.901462] iwlwifi 0000:02:00.0: Detected Intel(R) Wireless N 7260, REV=0x144
[    1.901553] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    1.901848] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    2.120085] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    2.125075] iwlwifi 0000:02:00.0 wlan1: renamed from wlan0
[    2.952782] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    2.953034] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    3.157418] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    3.157678] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[    3.760611] iwlwifi 0000:02:00.0 wlan1: disabling HT as WMM/QoS is not supported by the AP
[    3.760615] iwlwifi 0000:02:00.0 wlan1: disabling VHT as WMM/QoS is not supported by the AP

Any suggestions how to get this fixed?

2

You can install the missing firmware with

cd /lib/firmware
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/iwlwifi-7260-17.ucode

Then reboot into kernel 4.10

The iwlwifi-7260-17.ucode file is not in the linux-firmware package for 14.04

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.