8

When I run audacity I get the following error message:

The system has detected that another copy of Audacity is running. Running two copies of Audacity simultaneously may cause data loss or cause your system to crash.Use the New or Open commands in the currently running Audacity process to open multiple projects simultaneously.

I checked the system's monitor and there is NO audacity process running. At least not one that I can spot.

I rebooted and nothing happened.

3
  • 1
    You could try running killall audacity from a terminal window. Or simply log out and back in or reboot.
    – Byte Commander
    May 19, 2017 at 14:34
  • killall audacity worked! thanx : ) May 20, 2017 at 9:07
  • Nice. I elaborated that comment a bit and posted it as answer, so that you can accept it by clicking the grey round check button on its left to mark your question as solved. Thanks and welcome to Ask Ubuntu.
    – Byte Commander
    May 20, 2017 at 11:34

3 Answers 3

29

This bug also happens after a power failure. There is a lock file at /var/tmp/audacity-myusername/audacity-lock-myusername that does not get cleaned up after a hard shutdown. It will frustratingly prevent any new instances of audacity from being launched, even if you have no current instances running. Delete this file, and you're good to go.

1
2

If there are any audacity processes running, you can terminate them all by running the command below from a terminal window:

killall audacity

The alternative would be to wait and give it time to exit itself, as sometimes when you close an application window, the process might continue running in the background and tidying up stuff for some moments. Of course this doesn't help if the process isn't actually about to exit.

You could also simply log out of your user session and back in, or reboot the computer to make sure the process is ended.

1
  • Might be worth running pgrep audacity first, to see if there are any processes running, otherwise this won't help. In most cases, Audacity has probably left a lock file somewhere that needs to be deleted, as in the most popular answer.
    – mwfearnley
    Jun 20, 2020 at 15:51
1

I fixed the issue by removing this file

~/.audacity-data/audacity.cfg

The other solutions here didn't work for me.

When I reopened Audacity, I noticed that there was an unsaved project I hadn't closed properly.

This is with Audacity 2.1.2 On Ubuntu 16.04 LTS.

I found the answer here: https://forum.audacityteam.org/viewtopic.php?p=190837#p190837

This appears to happen with older version of Audacity, too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .