2

I have installed OpenVPN and I have downloaded the .ovpn file, but I am unable to import the file in Network SettingsVPNImport file option. Result:

Cannot import VPN connection
The filen vpn.ovpn could not be read or does not contain recognized VPN connection information
Error: configuration error: unsupported blob/xml element(line 78)

Any solution?

3

This Bug is around since ages in Ubuntu - See here: this bug on Launchpad here

The key to success is to strip out your inline certificates/keys into separate files, import the ovpn file and set the certificates manually.

| improve this answer | |
1

In my case, my ovpn file has the xml element <connection> </connection>, which is not supported by nmcli. Thus I remove <connection> </connection>, and it works

sudo nmcli connection import type openvpn file myvpn.conf

| improve this answer | |
0

If you want to use OpenVPN on XFCE/Xubuntu, you have to install the according "network-manager" tool first. Use this command:

sudo apt-get install network-manager-openvpn

and/or see here.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.