2

i'm trying to power on the keyboard backlight on my new laptop but every attempt has miserably failed. I've tried to use xset but nothing happens. I've been able to manually set the capslock led on/off but nothing else since i added acpi_osi= in my grub configuration. At least before that i could see the asus_airplane folder under /sys/class/leds and i could set it on/off too (now its gone) but the main backlight of the keyboard seems completely missing (i've seen the folder kbd_backlight referred in many forums).

Any ideas? Is possible the kernel has no clue my keyboard can do that? Thanks a lot, i wish i won't be forced to reinstall windows and virtualize ubuntu again :(

  • 1
    Which version of Ubuntu did you install? – Android Dev May 18 '17 at 22:33
  • So sorry for the long long time, frankly i moved back to windows after few hours i think, i i've even forgotten the request. Anyway i've never found a solution even if i retried not so long time ago! And have to say, Windows 10 sucks :) – Gianks Jun 14 '18 at 15:58
0

I had the same problem with my Toshiba laptop too. I searched the internet for weeks for a possible solution. Replacing GRUB_CMDLINE_LINUX="" with GRUB_CMDLINE_LINUX="acpi=off" in grub configuration fixed the keyboard backlight issue, but after disabling acpi, the usb-mouse, network card, FN keys didn’t work. Not even the laptop’s mouse pad worked! So, be careful with GRUB_CMDLINE_LINUX="acpi=off". If we can find a way to disable acpi and still have everything else working, that would be the answer to this problem.

  • Wow. I certainly won't use that solution. – Csaba Toth Mar 1 '18 at 16:58
  • Thanks for the suggestion but as you said it would be a nightmare with the entire PC then, not a good idea after all! – Gianks Jun 14 '18 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.