2

I tried to run on NFS from the terminal: mkdir a. I get the error message mkdir: cannot create directory ‘a’: Disk quota exceeded.

How can I see the quota that was allowed to me?


I tried quota -v, however I get the error message (my username is fr):

quota: error while getting quota from nfs-holy.mit.edu:/data for fr (id 24421): 
Connection refused

I tried sudo quota -v, but I get the same error message.

The output of df -h is:

Filesystem                                 Size  Used Avail Use% Mounted on
[…]
nfs-holy.mit.edu:/data                      50T   43T  7.8T  85% /data-nfs

The output of quota -v -f fr is:

quota: Cannot stat() given mountpoint fr: No such file or directory
Skipping...
quota: No correct mountpoint specified.
quota: Cannot initialize mountpoint scan.

The output of quota -v -f /data-nfs is:

quota: error while getting quota from nfs-holy.mit.edu:/data for fr (id 24421): 
Connection refused

I use Ubuntu 14.04.5 LTS x64.

2

Getting quota information from an NFS is... painful at times. It doesn't report normally, inquiries can easily be rejected and denied, and the quota inquiry doesn't necessarily go over the same exact communications vector as the standard NFS protocols.

The only true way would be to ask MIT what the disk quotas are. At Penn State, there is a directory on NFS/UNIX backed shares called the "PASS" drive, and the quota is modifiable from the user's logon page where they can access information about their logon account, PASS space, print quotas, etc. I would have to assume that MIT would have some type of similar dashboard somewhere, if not modifiable quotas.

I also found this document on MIT's Knowledge Base that suggests you're using the wrong command (but I don't know what Athena is nor what nfs-holy is at MIT), also. Try using quota -v -f MOUNT_POINT_ON_SYSTEM to get your quota information.

If that doesn't give you the information you're after (or says "Connection Refused"), then you might not have access to use that command, and will need to contact MIT IT and ask them to tell you what the quota you're allowed is. Then compare that to the total filesize of your files that you store on that share.

4
  • Thanks. I have added the output of quota -v -f $USER in the question. – Franck Dernoncourt May 18 '17 at 21:19
  • 1
    @FranckDernoncourt I blindly copy-pasted from the MIT KB document; try with the updated quota command in my answer - i realized they aren't accurate heh – Thomas Ward May 18 '17 at 21:20
  • Thanks. I have just added the output of quota -v -f /data-nfs in the question details: same error message as quota -v – Franck Dernoncourt May 18 '17 at 21:23
  • 1
    @FranckDernoncourt Since it's rejecting your request for quota data, you're out of luck and options, just draft an email to MIT's support help desk and ask them for assistance in figuring out your quota. – Thomas Ward May 18 '17 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.