46

I am trying to access Ubuntu 11.10 using Remote Desktop from a Win 7 machine. I installed xrdp. I launch the Windows remote desktop client and login in. I then get prompted for the user name and password.

It then logs in, but all I see is the background, no menus, nothing. I have to kill remote desktop by closing it.

Even if I right click , nothing. Any ideas???

The only reason I even went down the RDP road was that VNC would not work either, even after I enabled desktop sharing. I am in a bind as I need to connect to Ubuntu via Windows. In version 8 Ubuntu this was not an issue and it just worked.

4
  • When you say VNC wouldn't work, did it login ok but had the same desktop background-only problem, or could you not get it to connect at all?
    – Lozzy_uk
    Dec 30 '11 at 23:01
  • can you confirm you tried the trick in this answer? askubuntu.com/a/3936/14356
    – fossfreedom
    Dec 30 '11 at 23:22
  • I re-booted Ubuntu and now the VNC can connect but it is so slow it is not useable. I never had this problem with Ubuntu 8. Is this a bug in 11.10? When I log into Ubuntu with RDP what happens is that the screen re-sizes and you cannot access the menu bar along the top or the toolbar on the left. Also when logged in via rdf you cannot even right click on the desktop. It is weird, you can see the menu on the top show then rdp does something to re-size and it is gone. I have tried several rdp client like terminals, mRemote and MS remote desktop.
    – nitefrog
    Dec 31 '11 at 1:03
  • Yes, I have also tried to log in with a XP system and I get the exact same problem. All I see is a desktop image and no menus at all. I can log in but I ant do anything, no icons, no menus, no nothing. Even the items on my desktop are not there. Now if I use VNC I can see everything but the performance is so bad it is unsealable.
    – nitefrog
    Dec 31 '11 at 1:40

12 Answers 12

21

You might still have another desktop manager in your .xsession config.

cd /home/youruser
echo "gnome-session --session=ubuntu-2d" > .xsession
sudo /etc/init.d/xrdp restart

I've had a similar issue and this solved it.

5
  • 3
    You can add the 2nd line (echo...) in /etc/xrdp/startwm.sh before calling . /etc/X11/Xsession and it will work even if the .xsession file is modified by something else.
    – laurent
    Feb 9 '12 at 15:58
  • This solution worked beautifully for me. Cheers! Apr 1 '12 at 10:44
  • This didnt work for me, and I also have a connection lost problem :( askubuntu.com/questions/641240/… Jun 26 '15 at 10:06
  • This did not work for me. Specifying an XFCE session as in an answer below did. I wonder what else should I do. If this helped many others, it should be workable... Perhaps this is an old way, with so many changes in the session manager to this day. Nov 2 '20 at 14:14
  • This was a really old version of ubuntu. What I should have said was "Check your logs". /var/log/xrdp/xrdp-sesman.log Thanks @QA Collective.
    – txyoji
    Dec 9 '20 at 15:04
11

For future readers of this post (I found this post top of my Google search when I had the same problem), xrdp no longer seems to work with Ubuntu-2d in Ubuntu 14.04. Instead you must install xfce

sudo apt-get install xfce4

Then add the line

xfce4-session

to your ~/.xsession file instead of the gnome-session --session=ubuntu-2d line

5
  • This was my problem with Ubuntu 15.10
    – sngreco
    Feb 4 '16 at 19:27
  • Still does't work :(
    – Dmitry
    Sep 14 '17 at 4:17
  • 1
    This didn't work for me either, but what I would stress is to read the /var/log/xrdp/xrdp-sesman.log file and look for errors. This lead me to find my solution to this problem: github.com/neutrinolabs/xrdp/issues/764#issuecomment-304576785 Feb 26 '18 at 12:34
  • This worked for me BUT I also had to do the fix down below by adding a ` in front of my username when logging it. It wasn't immediately obvious that this fixed my issue because before I used ` in front of my username windows had saved the incorrect login with the windows domain added in front of the username. So it's a two part fix. May 7 '18 at 2:52
  • This worked for me. Nov 2 '20 at 14:15
3

Try this. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install gnome-session-fallback
echo “gnome-session -–session=gnome-fallback” > ~/.xsession
sudo /etc/init.d/xrdp restart
1

If I understood you correctly, you have Win 7 machine (rdp client) and ubuntu 11.10 (rdp server).

If you have unity 3d enabled in ubuntu, that will cause problems. Use gnome session fallback:

sudo apt-get install gnome-session-fallback

(you have to log out and select "gnome classic no effects")

..or xubuntu (xfce) :

sudo apt-get install xubuntu-desktop

..or lubuntu (lxde):

sudo apt-get install lubuntu-desktop

Also, try using rdesktop from command line. Looks like xrdp and other rdp gui programs don't support rdesktop's full capabilities, so it's best to use the command line directly.

rdesktop -h

3
  • 1
    I have tried it with the 2D version also and same issue. How do you use the command line from Win7 into Ubuntu?
    – nitefrog
    Dec 31 '11 at 1:05
  • that's a very good question.. I mixed up my answer with ubuntu-to-windows rdp connection. Sorry. Still, you can do it with cygwin, but the gui rdesktop client in windows works as expected :) Try the gnome-session-fallback, maybe you will have better results Jan 2 '12 at 21:15
  • @nitefrog Try Bitvise Tunnelier. It runs like a champ for terminal, FTP and RDP from Windows.
    – VidiMan
    Aug 18 '12 at 5:31
1

Add a backslash in front of your login, like: \yourlogin

This made it work for me. It removes the domain from your credential.

1
  • This worked for me but I also had to switch the .xsession file to use xfce in addition. May 7 '18 at 2:52
1

A limitation of the xrdp is that you can only login to desktop:0

I was logged in on the target machine as well as trying to connect. Once I logged out of the server I was able to login.

1

I had to do the following before it worked:

  • Install xfce4 and configure .xsession to "xfce4-session" as per Paul Rosenberg's reply above.

  • Fix a permissions problem with /etc/xrdp/ that caused the following error in /var/log/xrdp.log:

    [ERROR] Cannot read private key file /etc/xrdp/key.pem: Permission denied
    

    I added user xrdp to ssl-cert group, not sure if this is the best workaround though.

0

This is more of a workaround, but if you get a blank desktop, then there might be a question on the remote Ubuntu computer asking whether to refuse or allow. Just click the allow button from the alert.

0

Try a different desktop manager. While using lightdm I was getting a blank/black screen via XRDP. Once I switched to lxdm everything worked as expected.

0

I had the same "blank blue screen after login" problem using xrdp & xfce4 on Ubuntu 18.04.4 until I ended up here. "This issue is related to the xorgxrdp and certain changes implemented to Ubuntu 18.04 compared to the previous ones that have broken the xrdp capability"

In order to fix the issue, install xorgxrdp-hwe:

sudo apt-get install xorgxrdp-hwe-18.04

Then restart the xrdp service (daemon):

sudo /etc/init.d/xrdp restart
0

For 20.04 black screen issue is being fixed by adding gnome-session or xfce4-session to ~/.xsession file.

In my case I has been successfully logged in into gnome-session:

$ cat ~/.xsession
gnome-session
-1

See here, it's the best solution until now for Ubuntu 13.10. Scroll down see brian mullan's coments. I installed x2go and works like a charm on KDE Ubuntu 13.10 No more xrdp.

http://c-nergy.be/blog/?p=4448&cpage=1#comment-1013

Have a nice day all ...

1
  • Please provide a rough summary of what you're linking to, instead of just a link. :)
    – user98085
    Feb 13 '14 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.