I am trying to access Ubuntu 11.10 using Remote Desktop from a Win 7 machine. I installed xrdp. I launch the Windows remote desktop client and login in. I then get prompted for the user name and password.

It then logs in, but all I see is the background, no menus, nothing. I have to kill remote desktop by closing it.

Even if I right click , nothing. Any ideas???

The only reason I even went down the RDP road was that VNC would not work either, even after I enabled desktop sharing. I am in a bind as I need to connect to Ubuntu via Windows. In version 8 Ubuntu this was not an issue and it just worked.

  • When you say VNC wouldn't work, did it login ok but had the same desktop background-only problem, or could you not get it to connect at all? – Lozzy_uk Dec 30 '11 at 23:01
  • can you confirm you tried the trick in this answer? askubuntu.com/a/3936/14356 – fossfreedom Dec 30 '11 at 23:22
  • I re-booted Ubuntu and now the VNC can connect but it is so slow it is not useable. I never had this problem with Ubuntu 8. Is this a bug in 11.10? When I log into Ubuntu with RDP what happens is that the screen re-sizes and you cannot access the menu bar along the top or the toolbar on the left. Also when logged in via rdf you cannot even right click on the desktop. It is weird, you can see the menu on the top show then rdp does something to re-size and it is gone. I have tried several rdp client like terminals, mRemote and MS remote desktop. – nitefrog Dec 31 '11 at 1:03
  • Yes, I have also tried to log in with a XP system and I get the exact same problem. All I see is a desktop image and no menus at all. I can log in but I ant do anything, no icons, no menus, no nothing. Even the items on my desktop are not there. Now if I use VNC I can see everything but the performance is so bad it is unsealable. – nitefrog Dec 31 '11 at 1:40

13 Answers 13


You might still have another desktop manager in your .xsession config.

cd /home/youruser
echo "gnome-session --session=ubuntu-2d" > .xsession
sudo /etc/init.d/xrdp restart

I've had a similar issue and this solved it.

| improve this answer | |
  • 2
    You can add the 2nd line (echo...) in /etc/xrdp/startwm.sh before calling . /etc/X11/Xsession and it will work even if the .xsession file is modified by something else. – laurent Feb 9 '12 at 15:58
  • This solution worked beautifully for me. Cheers! – Matt Cashatt Apr 1 '12 at 10:44
  • i don't even want to know HOW you figured this out; just put the lines into the config - and it worked; thanks man +1 – Grigorash Vasilij May 29 '12 at 20:14
  • @laurent Beautiful! Simple brilliant – Yuriy Galanter Jul 12 '12 at 19:12
  • This solution worked for me. – Sitansu Jun 6 '13 at 6:16

For future readers of this post (I found this post top of my Google search when I had the same problem), xrdp no longer seems to work with Ubuntu-2d in Ubuntu 14.04. Instead you must install xfce

sudo apt-get install xfce4

Then add the line


to your ~/.xsession file instead of the gnome-session --session=ubuntu-2d line

| improve this answer | |
  • This was my problem with Ubuntu 15.10 – sngreco Feb 4 '16 at 19:27
  • Still does't work :( – Dmitry Sep 14 '17 at 4:17
  • This didn't work for me either, but what I would stress is to read the /var/log/xrdp/xrdp-sesman.log file and look for errors. This lead me to find my solution to this problem: github.com/neutrinolabs/xrdp/issues/764#issuecomment-304576785 – QA Collective Feb 26 '18 at 12:34
  • This worked for me BUT I also had to do the fix down below by adding a ` in front of my username when logging it. It wasn't immediately obvious that this fixed my issue because before I used ` in front of my username windows had saved the incorrect login with the windows domain added in front of the username. So it's a two part fix. – anon58192932 May 7 '18 at 2:52

Try this. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

sudo apt-get install gnome-session-fallback
echo “gnome-session -–session=gnome-fallback” > ~/.xsession
sudo /etc/init.d/xrdp restart
| improve this answer | |

If I understood you correctly, you have Win 7 machine (rdp client) and ubuntu 11.10 (rdp server).

If you have unity 3d enabled in ubuntu, that will cause problems. Use gnome session fallback:

sudo apt-get install gnome-session-fallback

(you have to log out and select "gnome classic no effects")

..or xubuntu (xfce) :

sudo apt-get install xubuntu-desktop

..or lubuntu (lxde):

sudo apt-get install lubuntu-desktop

Also, try using rdesktop from command line. Looks like xrdp and other rdp gui programs don't support rdesktop's full capabilities, so it's best to use the command line directly.

rdesktop -h

| improve this answer | |
  • 1
    I have tried it with the 2D version also and same issue. How do you use the command line from Win7 into Ubuntu? – nitefrog Dec 31 '11 at 1:05
  • that's a very good question.. I mixed up my answer with ubuntu-to-windows rdp connection. Sorry. Still, you can do it with cygwin, but the gui rdesktop client in windows works as expected :) Try the gnome-session-fallback, maybe you will have better results – Savvas Radevic Jan 2 '12 at 21:15

Add a backslash in front of your login, like: \yourlogin

This made it work for me. It removes the domain from your credential.

| improve this answer | |
  • This worked for me but I also had to switch the .xsession file to use xfce in addition. – anon58192932 May 7 '18 at 2:52

A limitation of the xrdp is that you can only login to desktop:0

I was logged in on the target machine as well as trying to connect. Once I logged out of the server I was able to login.

| improve this answer | |

I had to do the following before it worked:

  • Install xfce4 and configure .xsession to "xfce4-session" as per Paul Rosenberg's reply above.

  • Fix a permissions problem with /etc/xrdp/ that caused the following error in /var/log/xrdp.log:

    [ERROR] Cannot read private key file /etc/xrdp/key.pem: Permission denied

    I added user xrdp to ssl-cert group, not sure if this is the best workaround though.

| improve this answer | |

I have tried it with the 2D version also and same issue. How do you use the command line from Win7 into Ubuntu?

          – nitefrog Dec 31 '11 at 1:05

Try Bitvise Tunnelier. It runs like a champ for terminal, FTP and RDP from Windows.

| improve this answer | |
  • Bitvise is a bit buggy and will disconnect your sessions randomly. Better try Putty which is reliable and stable. – Denja Sep 14 '16 at 17:30

if you still have the problem,

you can have a look at this post, for me, it's seems well explained


Hope this will be helpfull for other as well

| improve this answer | |
  • 4
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eric Carvalho May 26 '13 at 15:07

This is more of a workaround, but if you get a blank desktop, then there might be a question on the remote Ubuntu computer asking whether to refuse or allow. Just click the allow button from the alert.

| improve this answer | |

Try a different desktop manager. While using lightdm I was getting a blank/black screen via XRDP. Once I switched to lxdm everything worked as expected.

| improve this answer | |

I had the same "blank blue screen after login" problem using xrdp & xfce4 on Ubuntu 18.04.4 until I ended up here. "This issue is related to the xorgxrdp and certain changes implemented to Ubuntu 18.04 compared to the previous ones that have broken the xrdp capability"

In order to fix the issue, install xorgxrdp-hwe:

sudo apt-get install xorgxrdp-hwe-18.04

Then restart the xrdp service (daemon):

sudo /etc/init.d/xrdp restart
| improve this answer | |

See here, it's the best solution until now for Ubuntu 13.10. Scroll down see brian mullan's coments. I installed x2go and works like a charm on KDE Ubuntu 13.10 No more xrdp.


Have a nice day all ...

| improve this answer | |
  • Please provide a rough summary of what you're linking to, instead of just a link. :) – user98085 Feb 13 '14 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.