0

This question already has an answer here:

Fetched 111 kB in 2s (41.4 kB/s)
Reading package lists... Done
W: http://extras.ubuntu.com/ubuntu/dists/precise/Release.gpg: Signature by key C47415DFF48C09645B78609416126D3A3E5C1192 uses weak digest algorithm (SHA1)
W: http://archive.canonical.com/ubuntu/dists/precise/Release.gpg: Signature by key 630239CC130E1A7FD81A27B140976EAF437D05B5 uses weak digest algorithm (SHA1)

root@chikki:/home/dharani# 

While updating using sudo apt-get update, I can see some warnings as shown above (6 warnings). I have searched a lot but could not find the solution.

I have also downloaded the Release.gpg file and it contains some binary data. Please help me in getting rid of this warning.

marked as duplicate by Byte Commander, muru, user364819, Eric Carvalho, David Foerster May 18 '17 at 22:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    Please note that Ubuntu 12.04 (Precise) reached the end of its support period last month. This does not only mean that your question is actually off-topic here as we don't support outdated releases, it also means that you should upgrade to a supported release like 14.04 LTS, 16.04 LTS or 17.04 (version number is YEAR.MONTH of the release date, LTS versions are supported for 5 years, normal versions for 9 months). You should also expect the 12.04 repositories to be moved to a different server any time soon, which would require you to reconfigure your software sources then. – Byte Commander May 18 '17 at 18:38
  • my ubuntu version is 16.04 LTS only. – dharani kaku May 20 '17 at 2:32
  • If your installed Ubuntu release is 16.04 though, you shouldn't even have that old repository for 12.04 enabled at all. Go to System Settings > Software & Updates and disable everything that mentions "precise" (the codename of 12.04). Alternatively, edit /etc/apt/sources.list and all files in /etc/apt/sources.list.d/ and comment out (write a # in front of the line) or delete all lines mentioning "precise" there. – Byte Commander May 20 '17 at 11:37
  • Thank you so much, for the reply. But i am getting many errors regarding unmet dependencies while installing other packages like php7.0 and sqlite3 .for eg: (have a look at this error which i got while installing php) The following packages have unmet dependencies: libapache2-mod-php7.1 : Depends: apache2-api-20120211 but it is not installable E: Unable to correct problems, you have held broken packages. please help me – dharani kaku May 21 '17 at 12:49
  • I suggest you post a new question about this issue, and include the full output of your install command (I guess sudo apt install php7.0) and of the command apt policy php7.0 libapache2-mod-php7.1 apache2-api-20120211 as well as the content of the files /etc/apt/sources.list and everything in /etc/apt/sources.list.d. If you want, you can then leave me the link to your new question here and I will have a look. – Byte Commander May 21 '17 at 15:09
2

Those warning messages can just be ignored. All repositories used to use SHA1 signatures, but it was found that SHA1 had problems, and they're converting over to SHA256 type of signature. Not all repositories have completed that transition.

If somebody can provide more technical details, please chime in.

Not the answer you're looking for? Browse other questions tagged or ask your own question.