1

I recently wanted to add a skin to Audacious, but when I went to add the skins files to the skins folder I was denied the action. Was greeted with "You are not the owner. You can not modify this folder"

I thought root had these privileges? Wasn't I automatically made the admin of my laptop when I installed Ubuntu? I am logged in to the admin account, not as a guest.

1

You are logged in as an account with root permissions available, but not enabled.

You can enable the permissions if you need, normally via the sudo command.

However, the sudo command is dangerous - there are no protections left once you run it. If you tell it to delete everything by mistake, it will.

To copy the files graphically, run this:

sudo -i nautilus /home/$USER

And move them to where they need to be. To copy with the command line use this:

cp "/current/location" "/new/location"
1

I'm assuming that by root you meant your account. root is a separate account which has the highest level privileges. You can switch to root by doing su. However, the preferred choice is to use the sudo command which is much less dangerous.

If you have some experience with terminal, try

sudo cp <origin> <destination> 

Else open the terminal and type

sudo -H nautilus 

This will open a file explorer with root privileges.

16.04 appears to have a problem with running nautilus from the terminal under sudo. Installing nautilus-admin is a great workaround for that.

  • 2
    You should not start graphical applications as root at all, especially not with plain sudo. See e.g. askubuntu.com/questions/270006/… . There is a Nautilus extension package called nautilus-admin though which adds a context menu option for opening a folder or editing a file as root easily and rather safely. It can be installed e.g. using sudo apt install nautilus-admin. – Byte Commander May 18 '17 at 18:01
  • Got Nautilus with root permissions to run....once. Now when I invoke with terminal I get the following: meshica7@meshica7-MacBookPro:~$ sudo -i nautilus /home/$USER [sudo] password for meshica7: (nautilus:6317): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed (nautilus:6317): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed Failed to register: Timeout was reached – Juan Leon May 18 '17 at 23:32
  • Could you give more information about the distro you're using? – RecursiveCursive May 19 '17 at 3:50
  • Ubuntu 16.04 LTS..default DE – Juan Leon May 19 '17 at 4:15
  • Install nautilus-admin with sudo apt-get install nautilus-admin, close all the available nautilus windows and then restart nautilus. It should work. – RecursiveCursive May 19 '17 at 4:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.