1

I have been using Ubuntu 16.04 for some time now on my Aser Aspire and never had any WiFi issues before. Today, after rebooting, the WiFi suddenly disappeared. It does not even search for networks. I have installed and enabled Broadcom in the Additional drivers tab. I have tried different commands found in the internet like installing bcmwl-kernel-source, installing b43-fwcutter, but they are all their newest versions. I cannot post full output because the only internet access I have is through my phone. Broadcom is listed in the output of lspci -knn

lspci -knn l grep Net -A3

02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10)
    Subsystem: Acer Incorporated [ALI] NetLink BCM57785 Gigabit Ethernet PCIe [1025:0504]
    Kernel driver in use: tg3
    Kernel modules: tg3
02:00.1 SD Host controller [0805]: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader [14e4:16bc] (rev 10)
--
03:00.0 Network controller [0280]: Broadcom Corporation BCM43227 802.11b/g/n [14e4:4358]
    Subsystem: Foxconn International, Inc. BCM43227 802.11b/g/n [105b:e040]
    Kernel driver in use: bcma-pci-bridge
    Kernel modules: bcma, wl
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3 terminal command. You can copy the output to a file and post it from some other device. – Pilot6 May 18 '17 at 16:36
0

Probably you have updated linux kernel, somewhere around release of 4.10 support of broadcom-wl got lagging behind. There are some patches that may fix it, but for now just stick to older kernel

2

You need to disable Secure Boot in BIOS.

You probably did not upgrade your system for a long time and now installed a new kernel that requires Secure Boot disabled to load 3rd party modules.

See Why do I get "Required key not available" when install 3rd party kernel modules or after a kernel upgrade?

  • I cannot find the secure boot option in my bios. It has tabs Information, Main, Security, Boot and exit and neither has secure boot – Hristo Vrigazov May 18 '17 at 19:23
  • I can't find it for you. The output shows that wl is installed, but not in use. This means that SB does not let it load. What does sudo modprobe wl output? – Pilot6 May 18 '17 at 19:33
  • It does not output anything. Well, I don't have the secure option anywhere in the Bios, do I have an alternative? – Hristo Vrigazov May 18 '17 at 19:44
  • If it does not output anything, then wl could load. Does it show as "in use"? – Pilot6 May 18 '17 at 19:52
  • Where? After I run thr lspci -knn command it still shows only bcma-pci-bridge in use if that is what you are asking. – Hristo Vrigazov May 18 '17 at 20:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.