11

I have a Sony Vaio SVF142C1WW with 64-bit Ubuntu 17.04 installed. Every time it resumes from being suspended, neither the keyboard nor touchpad work for a few seconds. Then the touchpad becomes responsive but the keyboard still remains non-responsive.

I recently upgraded from Ubuntu 16.10 where both the keyboard and touchpad did become responsive after a few seconds of non-responsiveness. I've tried answers to this and this but nothing worked. What else can I try?

1
  • Switched to kernel version 4.8 and the keyboard works fine now. Will I run into any troubles because of this change? May 18, 2017 at 19:10

8 Answers 8

12

@Saif has found the underlying driver which is behind the issue. However setting dumbkbd and direct is unnecessary / disables system control of LEDs like Caps-Lock.

For most vaios instead resetting the controller will also correct the problem whilst maintaining this functionality. I.e. in the grub config file -

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"

Then

sudo update-grub
2
  • 1
    Can confirmed this with a laptop - model N150RF1 (Brand varies). Have never been able to use the keyboard after a shutdown before this
    – daramarak
    May 20, 2018 at 23:30
  • 1
    NOTE : This does not work on Sony Vaio SVF series. Only i8042.dumbkbd works, and there is no way around the led bug.
    – Aditya T
    Dec 22, 2020 at 6:06
11

Basically, run this in a shell to confirm you are applicable to this solution:

dmesg | grep i8042

and confirm you get this output

[ 1.514469] i8042: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:MOUE] at 0x60,0x64 irq 1,12
[ 1.525273] serio: i8042 KBD port at 0x60,0x64 irq 1
[ 1.525287] serio: i8042 AUX port at 0x60,0x64 irq 12
[ 1.526035] input: AT Raw Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
[ 21.927438] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input10

then, add the boot parameters i8042.direct and i8042.dumbkbd to /etc/default/grub. For example, run

sudo nano /etc/default/grub

Find the line that begins GRUB_CMDLINE_LINUX_DEFAULT= and edit it to include the new parameters, so that after your edit it looks something like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.direct i8042.dumbkbd"

Save by pressing Ctrl+O, exit by pressing Ctrl+X, and run

sudo update-grub

Source: Some time traveler here on Ubuntu Forums

8
  • 1
    That's an old post. Why do you think it will work here?
    – Zanna
    Jul 27, 2017 at 12:47
  • 2
    Because I was facing the issue yesterday, with latest kernel and latest distro release. And it was hard to find a solution specific for Vaio laptopts. This might be handy for other victims like me, since this solved the issue.
    – Saif
    Jul 27, 2017 at 17:52
  • so it worked for you? that's great if so! :)
    – Zanna
    Jul 27, 2017 at 17:53
  • 1
    It worked but CapsLock, NumLock lights always on. So something is wrong here!
    – Ceylan B.
    Aug 30, 2018 at 15:41
  • 2
    Worked on Ubuntu 20.10 with Sony Vaio SVF series laptop, there is no way around led light no bug, touchpad touch click not working bug , so restart is needed to restore fully working system.
    – Aditya T
    Dec 22, 2020 at 6:09
1

My ThinkPad E531 mouse and suspend functions works again after:

GRUB_CMDLINE_LINUX_DEFAULT="atkbd.reset=1 i8042.nomux=1 i8042.reset=1 i8042.nopnp=1 i8042.dumbkbd=1 quiet splash"
sudo update-grub
1

For the VAIO model vjf152 sold in Japan only, the solution is to replace content in GRUB_CMDLINE_LINUX_DEFAULT with atkdb.reset i8042.nomux quiet splash and then do sudo update-grub.

Found this on a Japanese forum: https://obelisk.hatenablog.com/category/Linux?page=1483896200

0

I had same issue on my PC with Ubuntu 16.04. After returning from Suspend mode the password input box was not responding to keyboard events (was not even blinking). Reconnecting USB keyboard did not help. I could switch with Ctrl+F2 to terminal. The keyboard worked - just the input box did not.

Open grub default config file:

sudo gedit /etc/default/grub

Change line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset"

run

sudo update-grub

and then reboot ubuntu.

0

Although I couldn't get any proper permanent solutions to this problem, I could find a workaround.

What I did was, turn on On-Screen Keyboard, Press CapsLock on the On-Screen Keyboard, and turn it back off.

And Voila, the keyboard started working Again!!!

But as I said, it's not permanent, you have to do this Everytime.

0

There is one weird thing that worked for me. My laptop is HP Elitebook 8460p. When I have such a problem, I press Power button on the laptop to make it sleep again. Then I press Power button again to wake it up. And the keyboard works.. I have no idea why it is so...

0

I have the exact same problem on my Hp pro book running ubuntu 21.10. Everytime I suspend the computer and resume it the keyboard doesn’t work, i simple just press the power button to go back into suspend and resume it again and voila the keyboard works again. Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.