6

i keep getting this error. I am not sure how to get rid of it. I am using NVIDIA drivers 381.22 does that cause this problem?

i tried everything from here: My dconf/gsettings installation is broken. How can I fix it without Ubuntu reinstall? no luck

7

I get that message when I try to use gsettings directly (seems unrelated to Nvidia driver), and it looks like it is caused by anaconda or miniconda installing their own version of glib. For me, which gsettings shows gsettings within the conda folder tree. If I change my commands from, for example:

gsettings set org.gnome.Evince.Default show-sidebar false

to explicitly calling the system version of gsettings:

/usr/bin/gsettings set org.gnome.Evince.Default show-sidebar false

they don't give that using "memory" backend message, and the setting sticks.

  • I ran into the same problem helping someone trying to disable encryption for Vino: gsettings set org.gnome.Vino require-encryption false – Compholio Oct 5 '17 at 18:26
  • This was the (incredibly difficult to find) answer that did it for me. Intuitive way to check / solve the problem! – benjaminmgross Jan 12 '18 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.