0

I recently bought a new laptop, a Dell Inspiron 15 7560 i7, and have dual booted Ubuntu Gnome 17.04.

I am facing an issue with the sound card, it just randomly stops working, no sound produced whatsoever. Normally when this happens I am on a headphone or just connected a headphone (like, removed and reconnected etc). The headphone is a standard JBL mic+speaker headphone with a 3.5 audio jack. I have already tried installing alsa, using alsamixer to change volumes, restarting pulseaudio (pulseaudio -k && sudo alsa force-reload) etc. Output of aplay -l:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

When this happens Ubuntu starts showing some additional HDMI (DisplayPort) devices in Sound settings (screenshot), and headphone option even after removing headphones, these devices are not listed normally. If I restart, it boots and shows a 'Dummy Output' under sound settings. This is how it looks when broken: Many new devices listed under sound options

The only thing I have seen to work so far is a shutdown, wait, and a startup (not a restart command), that too not guaranteed, but sound does come back again a few restarts later.

Interestingly, if I restart into Windows 10 when it is broken, even Windows does not produce sound, shows a 'red cross' on the speaker icon in system tray. Dell support has already upgraded my BIOS, motherboard drivers and Sound drivers in Windows because of this, but I do not see how that matters, except for BIOS upgrade.

Is this a hardware issue?

Updates:

  • I figured out while trying different things that if I use an external sound card, i.e. the digital adaptor for headphones to provide USB connectivity or a USB headphone itself this issue does not occur.
  • If before disconnecting the headphones I switch the output device to 'Speakers built-in audio' in settings and then disconnect headphones the issue does not occur. But I have to do this every time; or a shutdown is required. This does not look like a hardware issue based on the two points above. It seems like a software issue. Hoping some update to OS fixes it.

Updates 2:

  • When I am trying to do a shutdown to reset audio devices, I am seeing better success when the power is disconnected while this shutdown-restart-cycle.
  • I need to switch the output device to built-in and disconnect headphones before closing the lid or the issue occurs on wake.
8
  • If you still have warranty on your laptop, I would play it save and let the vendor have another look at it to make sure there are no loose wires.
    – user680858
    May 18, 2017 at 14:28
  • @WillemK Raised a request, they replaced the speakers, but the issue persists. There were no loose screws or wires. :( Anything else I should try? May 29, 2017 at 3:11
  • If the error only occurs in Ubuntu 17, I would install 16.04 LTS and see how things respond in there. v17 is still very new, maybe there are still bugs that need resolving.
    – user680858
    May 29, 2017 at 12:56
  • Just did that. Uninstalled Ubuntu 17 and installed Linux mint 18.1, which is based on Ubuntu 16.04 LTS and know to be working stably on my work laptop. Still the same issue. Is there a way I can make the hardware searched again? The headphones are listed even after removing them.. May 29, 2017 at 17:07
  • You removed the headphones but not the hardware controlling them. You would have to remove the whole sound card, but that is probably embedded in the laptop. Un-installing the driver is the closest thing to removing hardware, unless there is an option in BIOS to turn them off? Otherwise I have no other ideas how to resolve this issue, except but to install Ubuntu as a VM in Vmware Player in Windows.
    – user680858
    May 30, 2017 at 1:54

1 Answer 1

0

When this issue was observed I was on Ubuntu Gnome, over time I moved to Linux Mint 18.1, then 18.2 and 18.3 and the issue still persisted. It had certainly less to do with the specific OS and more with the drivers and kernel it seems.

Dell has been consistently releasing BIOS software updates. I am currently on BIOS version 1.3.0 (Release Date: 09/11/2017) and kernel version 4.13.0-36-generic and noticing that I no longer have this problem. It stopped a few kernel updates ago, but I waited to observe/confirm.

There have been further updates to BIOS (latest version as of this post is 1.5.4) and so to kernel, but I have not tested them. Unless a regression occurs they should work. Will revert if the issue occurs again after any update, till then let's consider this as fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.